1SUMMARY = "Filesystem and Disk Benchmarking Tool"
2HOMEPAGE = "http://www.iozone.org/"
3SECTION = "console/tests"
4LICENSE = "iozone3"
5LIC_FILES_CHKSUM = "file://iozone.c;beginline=37;endline=48;md5=7331260091868dcad0f9edea735b5f4b \
6    file://iozone.c;beginline=276;endline=282;md5=77f9ee51e45b57a7e7519c4fa0b4f00b \
7"
8SRC_URI = "http://www.iozone.org/src/current/${BPN}_${PV}.tar \
9    file://parallelism.patch \
10    file://0001-let-system-headers-provide-pread64.patch \
11    file://copyright.txt \
12"
13SRC_URI[sha256sum] = "114ce5c071873b9a2c7ba6e73d05d5ef7e66564392acbfcdc0b3261db10fcbe7"
14
15UPSTREAM_CHECK_REGEX = "iozone3_(?P<pver>\d+).tar"
16
17S = "${WORKDIR}/${BPN}_${PV}/src/current"
18
19#
20# All other arches can use the default OEMAKE except those
21# explicitly listed below. Another, the iozone3 Makefile
22# needs to be told about the cross-compiler explicitly here.
23#
24EXTRA_OEMAKE:powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
25EXTRA_OEMAKE:powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
26EXTRA_OEMAKE:powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
27EXTRA_OEMAKE:x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'"
28EXTRA_OEMAKE:arm = "linux-arm CC='${CC}' GCC='${CC}'"
29EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'"
30
31TARGET_CC_ARCH += "${LDFLAGS}"
32
33do_install() {
34    install -d ${D}${bindir} \
35               ${D}${mandir}/man1 \
36               ${D}${datadir}/doc/${BPN}/examples
37
38    install -m 0755 ${S}/iozone ${D}${bindir}
39    install -m 0755 ${S}/fileop ${D}${bindir}
40    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
41    install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${BPN}/
42
43    install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${BPN}/examples
44    install -m 0644 ${S}/client_list ${D}${datadir}/doc/${BPN}/examples
45    install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${BPN}/examples
46
47    install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${BPN}/examples
48    install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${BPN}/examples
49    install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${BPN}/examples
50
51    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${BPN}/
52    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${BPN}/
53    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${BPN}/
54}
55
56FILES:${PN} += "${datadir}/doc/${PN}/copyright.txt"
57
58# LICENSE:
59#
60#  Copyright 1991, 1992, 1994, 1998, 1999, 2002   William D. Norcott
61#
62#  License to freely use and distribute this software is hereby granted
63#  by the author, subject to the condition that this copyright notice
64#  remains intact.  The author retains the exclusive right to publish
65#  derivative works based on this work, including, but not limited to
66#  revised versions of this work.
67#
68
69#
70# Below is author reply to question about distributing iozone3 in
71# OpenEmbedded:
72#
73# ========================================================================
74#
75# Marcin,
76#
77#     Re-distribution is permitted as long as the copyright is
78#     maintained and the source code is not changed. I do not
79#     see a problem with your mods to enable fileop for Linux-arm,
80#     as these mods have been returned to the Iozone folks,
81#     and they have been accepted for inclusion in the next
82#     release :-)
83#
84# Thank you for your contribution,
85# Don Capps
86#
87# ----- Original Message -----
88# From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
89# To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
90# <wnorcott@us.oracle.com>
91# Sent: Sunday, October 29, 2006 4:55 PM
92# Subject: iozone3 263 patch for arm and License question
93#
94#
95# > Morning
96# >
97# > I want to include iozone3 in OpenEmbedded [1] metadata to give it for
98# > other developers. Currently OE is used to build few distributions for
99# > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
100# > machines (PDA, settopbox, devboards, desktops, thin clients, routers).
101# >
102# > According to your distribution of derivations is forbidden. Packaging
103# > iozone3 in OpenEmbedded will not involve any source code changes. But
104# > when I was building it for ARM I discovered that fileop binary was not
105# > built - so I created patch for it (attached). Not yet tested it on target
106# > device.
107# >
108# > Thus, I seek your written permission via e-mail to distribute a package of
109# > the unmodified source code and also a package of the pre-compiled binary.
110# > Your copyright statement will be included in the package.
111# >
112# >
113# > 1. http://www.openembedded.org/
114# >
115# > Regards
116# > --
117# > JID: hrw-jabber.org
118# > OpenEmbedded developer/consultant
119
120