1SUMMARY = "wavemon is a wireless device monitoring application"
2HOMEPAGE = "https://github.com/uoaerg/wavemon"
3DESCRIPTION = "wavemon is a wireless device monitoring application that \
4	allows you to watch signal and noise levels, packet \
5	statistics, device configuration and network parameters of \
6	your wireless network hardware."
7
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
10
11PACKAGECONFIG ??= "cap"
12PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
13
14DEPENDS = "libnl ncurses"
15
16SRC_URI = "git://github.com/uoaerg/wavemon;branch=master;protocol=https"
17SRCREV = "8ba6604027c0aa5131070e3fafdcda323d58a7ad"
18
19# Needs some help to find libnl3 headers.
20# Reorder -pthread flag on the command line.
21EXTRA_OEMAKE = "\
22    CC='${CC}' CFLAGS='${CFLAGS} -pthread -I${STAGING_INCDIR}/libnl3' \
23"
24
25S = "${WORKDIR}/git"
26
27# wavemon does not support using out-of-tree builds
28inherit autotools-brokensep pkgconfig
29