1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "https://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPL-3.0-or-later"
5
6DEPENDS += "libtalloc libtirpc cmocka"
7RDEPENDS:python3-tevent = "python3"
8
9export PYTHONHASHSEED="1"
10export PYTHONARCHDIR = "${PYTHON_SITEPACKAGES_DIR}"
11
12SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
13           file://0001-Add-configure-options-for-packages.patch \
14           file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
15           file://run-ptest \
16          "
17
18LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=47386b7c539bf2706b7ce52dc9341681"
19
20SRC_URI[sha256sum] = "1aa58f21017ed8c2f606ae84aa7e795b5439edd4dd5f68f1a388a7d6fb40f682"
21
22inherit pkgconfig ptest waf-samba
23
24PACKAGECONFIG ??= "\
25    ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
26    ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
27"
28PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
29PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
30PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
31PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
32PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
33
34SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
35
36S = "${WORKDIR}/tevent-${PV}"
37
38# Cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
39# to cross Popen
40export WAF_NO_PREFORK="yes"
41
42EXTRA_OECONF += "--disable-rpath \
43                 --disable-rpath-install \
44                 --bundled-libraries=NONE \
45                 --builtin-libraries=replace \
46                 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
47                 --without-gettext \
48                "
49
50do_install_ptest() {
51    install -d ${D}${PTEST_PATH}/tests
52    install -m 0755 ${B}/bin/test_tevent_* ${D}${PTEST_PATH}/tests/
53    install -m 0755 ${B}/bin/replace_testsuite ${D}${PTEST_PATH}/tests/
54}
55
56PACKAGES += "python3-tevent"
57
58RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
59
60FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
61
62INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"
63