1SUMMARY = "Dovecot is an open source IMAP and POP3 email server"
2HOMEPAGE = "https://www.dovecot.org/"
3DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
4SECTION = "mail"
5LICENSE = "LGPL-2.1-only & MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2956560272e5b31d9d64f03111732048"
7
8SRC_URI = "http://dovecot.org/releases/2.3/dovecot-${PV}.tar.gz \
9           file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
10           file://dovecot.service \
11           file://dovecot.socket \
12           file://0001-not-check-pandoc.patch \
13           file://0001-m4-Check-for-libunwind-instead-of-libunwind-generic.patch \
14           "
15SRC_URI[sha256sum] = "05b11093a71c237c2ef309ad587510721cc93bbee6828251549fc1586c36502d"
16
17DEPENDS = "openssl xz zlib bzip2 libcap icu libtirpc bison-native"
18CFLAGS += "-I${STAGING_INCDIR}/tirpc"
19LDFLAGS += "-ltirpc"
20
21inherit autotools pkgconfig systemd useradd gettext multilib_header
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam systemd', d)}"
24
25PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
26PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd,"
27PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
28PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
29
30# From native build in armv7a-hf/eglibc
31CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
32                         i_cv_gmtime_max_time_t=32 \
33                         i_cv_signed_time_t=yes \
34                         i_cv_mmap_plays_with_write=yes \
35                         i_cv_fd_passing=yes \
36                         i_cv_c99_vsnprintf=yes \
37                         lib_cv___va_copy=yes \
38                         lib_cv_va_copy=yes \
39                         lib_cv_va_val_copy=yes \
40                        "
41
42# hardcode epoll() to avoid running unsafe tests
43# BSD needs kqueue and uclibc poll()
44EXTRA_OECONF = " --with-ioloop=epoll"
45
46SYSTEMD_PACKAGES = "${PN}"
47SYSTEMD_SERVICE:${PN} = "dovecot.service dovecot.socket"
48SYSTEMD_AUTO_ENABLE = "disable"
49
50do_install:append () {
51    rm -rf ${D}${libdir}/dovecot/dovecot-config
52    install -d 755 ${D}/etc/dovecot
53    touch 644 ${D}/etc/dovecot/dovecot.conf
54    if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
55        install -m 0644 ${WORKDIR}/dovecot.service ${D}${systemd_unitdir}/system
56        sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/dovecot.service
57        sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/dovecot.service
58    fi
59    oe_multilib_header dovecot/config.h
60}
61
62USERADD_PACKAGES = "${PN}"
63USERADD_PARAM:${PN} = "-r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovecot dovecot; \
64                      -r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovenull dovenull"
65GROUPADD_PARAM:${PN} = "-f -r dovecot;-f -r dovenull"
66
67FILES:${PN} += "${libdir}/dovecot/*plugin.so \
68                ${libdir}/dovecot/libfs_compress.so \
69                ${libdir}/dovecot/libssl_iostream_openssl.so"
70FILES:${PN}-staticdev += "${libdir}/dovecot/*/*.a"
71FILES:${PN}-dev += "${libdir}/dovecot/libdovecot*.so"
72FILES:${PN}-dbg += "${libdir}/dovecot/*/.debug"
73
74CVE_STATUS[CVE-2016-4983] = "not-applicable-platform: Affects only postinstall script on specific distribution."
75