1SUMMARY = "Client for Microsoft PPTP VPNs"
2DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
3    and OpenBSD client for the proprietary Microsoft Point-to-Point \
4    Tunneling Protocol, PPTP. Allows connection to a PPTP based \
5    Virtual Private Network (VPN) as used by employers and some \
6    cable and ADSL internet service providers."
7HOMEPAGE = "http://pptpclient.sourceforge.net"
8SECTION = "net"
9LICENSE = "GPL-2.0-or-later"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12inherit perlnative
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
15           file://options.pptp \
16           "
17
18SRC_URI[md5sum] = "8d25341352fdae5ad5b36b9f18254908"
19SRC_URI[sha256sum] = "82492db8e487ce73b182ee7f444251d20c44f5c26d6e96c553ec7093aefb5af4"
20
21S = "${WORKDIR}/pptp-${PV}"
22
23EXTRA_OEMAKE = "-e MAKEFLAGS="
24
25do_install() {
26    install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
27    install -m 555 pptp ${D}${sbindir}
28    install -m 644 pptp.8 ${D}${mandir}/man8
29    install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
30}
31
32RDEPENDS:${PN} = "ppp"
33