1SUMMARY = "Vorbis Tools"
2DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
3that is free of intellectual property restrictions. vorbis-tools \
4include some command line applications to use the libraries."
5HOMEPAGE = "http://www.vorbis.com/"
6BUGTRACKER = "https://trac.xiph.org"
7SECTION = "multimedia"
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
10
11DEPENDS = "libogg libvorbis"
12
13SRC_URI = "http://downloads.xiph.org/releases/vorbis/${BP}.tar.gz \
14           file://gettext.patch \
15           file://0001-ogginfo-Include-utf8.h-for-missing-utf8_decode.patch \
16          "
17
18SRC_URI[md5sum] = "998fca293bd4e4bdc2b96fb70f952f4e"
19SRC_URI[sha256sum] = "db7774ec2bf2c939b139452183669be84fda5774d6400fc57fde37f77624f0b0"
20
21inherit autotools pkgconfig gettext
22
23PACKAGECONFIG ??= "flac ogg123"
24PACKAGECONFIG[flac] = ",--without-flac,flac,libflac"
25PACKAGECONFIG[speex] = ",--without-speex,speex,speex"
26PACKAGECONFIG[ogg123] = "--enable-ogg123,--disable-ogg123,libao curl"
27