1SUMMARY = "A DSP library for telephony"
2DESCRIPTION = "\
3    SpanDSP is a low-level signal processing library that modulates and \
4    demodulates signals commonly used in telephony, such as the \"noise\" \
5    generated by a fax modem or DTMF touchpad. \
6"
7HOMEPAGE = "https://www.soft-switch.org/"
8BUGTRACKER = "https://github.com/freeswitch/spandsp/issues"
9SECTION = "libs"
10LICENSE = "LGPL-2.1-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=8791c23ddf418deb5be264cffb5fa6bc"
12
13DEPENDS = "\
14    libxml2 \
15    tiff \
16    tiff-native \
17"
18
19PV = "3.0.0+git"
20
21SRC_URI = "\
22    git://github.com/freeswitch/spandsp.git;protocol=https;branch=master \
23    file://configure.patch \
24    file://makefile.patch \
25"
26# Fails to build with Clang since 5394b2cae6c482ccb835335b769469977e6802ae
27# https://github.com/freeswitch/spandsp/issues/67
28# https://lists.openembedded.org/g/openembedded-devel/message/109325
29SRCREV = "df1282eb9af538ab1aadb6d66146e258451d4fe4"
30
31S = "${WORKDIR}/git"
32
33inherit autotools
34
35PACKAGECONFIG ?= ""
36
37PACKAGECONFIG[mmx] = "--enable-mmx,--disable-mmx"
38PACKAGECONFIG[sse] = "--enable-sse,--disable-sse"
39PACKAGECONFIG[sse2] = "--enable-sse2,--disable-sse2"
40PACKAGECONFIG[sse3] = "--enable-sse3,--disable-sse3"
41PACKAGECONFIG[ssse3] = "--enable-ssse3,--disable-ssse3"
42PACKAGECONFIG[sse4-1] = "--enable-sse4-1,--disable-sse4-1"
43PACKAGECONFIG[sse4-2] = "--enable-sse4-2,--disable-sse4-2"
44PACKAGECONFIG[avx] = "--enable-avx,--disable-avx"
45PACKAGECONFIG[avx2] = "--enable-avx2,--disable-avx2"
46PACKAGECONFIG[neon] = "--enable-neon,--disable-neon"
47PACKAGECONFIG[fixed-point] = "--enable-fixed-point,--disable-fixed-point"
48PACKAGECONFIG[v32bis] = "--enable-v32bis,--disable-v32bis"
49PACKAGECONFIG[v34] = "--enable-v34,--disable-v34"
50PACKAGECONFIG[sslfax] = "--enable-sslfax,--disable-sslfax"
51