1LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
3inherit meson pkgconfig systemd
4
5PACKAGECONFIG ??= ""
6PACKAGECONFIG[libpeci] = "-Dlibpeci=enabled,-Dlibpeci=disabled"
7PACKAGECONFIG[crashdump] = "-Dcrashdump=enabled,-Dcrashdump=disabled"
8PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=enabled,-Dsend-to-logger=disabled"
9
10EXTRA_OEMESON += "-Dtests=disabled"
11
12SRC_URI = "git://github.com/openbmc/host-error-monitor;branch=master;protocol=https"
13
14DEPENDS = "boost sdbusplus libgpiod libpeci phosphor-dbus-interfaces"
15
16PV = "0.1+git${SRCPV}"
17SRCREV = "a4f8e5fe0deae7eee2a55a860648675089476af4"
18
19S = "${WORKDIR}/git"
20
21SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
22