1SUMMARY = "Initialize PWM sensors"
2DESCRIPTION = "Initialize PWM sensors"
3LICENSE = "CLOSED"
4PR = "r1"
5
6inherit systemd
7
8DEPENDS = "systemd"
9RDEPENDS:${PN} = "bash"
10
11S = "${WORKDIR}/sources"
12UNPACKDIR = "${S}"
13FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
14SRC_URI += " \
15    file://pwm_init.service \
16    file://bin/pwm_init.sh \
17    "
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_AUTO_ENABLE = "enable"
21SYSTEMD_SERVICE:${PN} += "pwm_init.service"
22
23FILES:${PN} += "${bindir}/* ${systemd_system_unitdir}/*"
24
25do_install:append() {
26    install -d ${D}${libexecdir}/${PN}
27    install -m 0755 ${S}/bin/* ${D}${libexecdir}/${PN}/
28    install -d ${D}${systemd_system_unitdir}
29    install -m 0644 ${S}/*.service ${D}${systemd_system_unitdir}
30}
31