1SUMMARY = "Initialize PWM sensors"
2DESCRIPTION = "Initialize PWM sensors"
3LICENSE = "CLOSED"
4PR = "r1"
5
6inherit systemd
7
8DEPENDS = "systemd"
9RDEPENDS:${PN} = "bash"
10
11S = "${WORKDIR}"
12FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
13SRC_URI += " \
14    file://pwm_init.service \
15    file://bin/pwm_init.sh \
16    "
17
18SYSTEMD_PACKAGES = "${PN}"
19SYSTEMD_AUTO_ENABLE = "enable"
20SYSTEMD_SERVICE:${PN} += "pwm_init.service"
21
22FILES:${PN} += "${bindir}/* ${systemd_system_unitdir}/*"
23
24do_install:append() {
25    install -d ${D}${libexecdir}/${PN}
26    install -m 0755 ${S}/bin/* ${D}${libexecdir}/${PN}/
27    install -d ${D}${systemd_system_unitdir}
28    install -m 0644 ${S}/*.service ${D}${systemd_system_unitdir}
29}
30