1SUMMARY = "foxconn OEM IPMI commands"
2DESCRIPTION = "foxconn OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7S = "${WORKDIR}/git"
8
9DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
10
11inherit cmake pkgconfig obmc-phosphor-ipmiprovider-symlink
12
13EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
14
15LIBRARY_NAMES = "libfiioemcmds.so"
16
17SRC_URI = "git://github.com/openbmc/foxconn-ipmi-oem.git;branch=master;protocol=https"
18SRCREV = "9d6c4010b58049070afcb39ef4c2a965633e2e9c"
19
20HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
21NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22
23FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
27