xref: /openbmc/openbmc/poky/meta/recipes-sato/webkit/wpebackend-fdo_1.14.3.bb (revision 8460358c3d24c71d9d38fd126c745854a6301564)
1SUMMARY = "WPE's backend based on a freedesktop.org stack."
2HOMEPAGE = "https://github.com/Igalia/WPEBackend-fdo"
3BUGTRACKER = "https://github.com/Igalia/WPEBackend-fdo/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1f62cef2e3645e3e74eb05fd389d7a66"
7DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe libepoxy"
8
9DEPENDS:append:class-target = " wayland-native"
10
11inherit meson features_check pkgconfig
12
13REQUIRED_DISTRO_FEATURES = "opengl"
14
15SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
16SRC_URI[sha256sum] = "10121842595a850291db3e82f3db0b9984df079022d386ce42c2b8508159dc6c"
17
18# Especially helps compiling with clang which enable this as error when
19# using c++11
20CXXFLAGS += "-Wno-c++11-narrowing"
21
22# This is a tweak of upstream-version-is-even needed because
23# ipstream directory contains tarballs for other components as well.
24UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"
25