xref: /openbmc/openbmc/meta-raspberrypi/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend (revision 213cb2696d00a85cd48d356cb5131824a302d828)
1PACKAGECONFIG_GL:rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \
2                        bb.utils.contains('DISTRO_FEATURES',     'opengl', 'eglfs gles2', \
3                                                                       '', d), d)}"
4PACKAGECONFIG_GL:append:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', ' kms', '', d)}"
5PACKAGECONFIG_GL:append:rpi = " gbm"
6PACKAGECONFIG_FONTS:rpi = "fontconfig"
7PACKAGECONFIG:append:rpi = " libinput examples tslib xkbcommon"
8PACKAGECONFIG:remove:rpi = "tests"
9
10OE_QTBASE_EGLFS_DEVICE_INTEGRATION:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'eglfs_brcm', d)}"
11
12do_configure:prepend:rpi() {
13    # Add the appropriate EGLFS_DEVICE_INTEGRATION
14    if [ "${@d.getVar('OE_QTBASE_EGLFS_DEVICE_INTEGRATION')}" != "" ]; then
15        echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" >> ${S}/mkspecs/oe-device-extra.pri
16    fi
17}
18RDEPENDS:${PN}:append:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
19DEPENDS:append:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
20