xref: /openbmc/openbmc/meta-phosphor/recipes-phosphor/misc/phosphor-misc_git.bb (revision 03ec3a9fd9f32689f1cd98f4bb1f602953350cb5)
1SUMMARY = "Miscellaneous OpenBMC functions"
2HOMEPAGE = "https://github.com/openbmc/phosphor-misc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5DEPENDS = "systemd"
6SRCREV = "6b7fa8193250fa61f0c44ca54480fc42974817dc"
7PACKAGECONFIG ??= " \
8    first-boot-set-hostname \
9    first-boot-set-mac \
10    http-redirect-awk \
11    usb-ctrl \
12    "
13PACKAGECONFIG[first-boot-set-hostname] = "-Dfirst-boot-set-hostname=enabled, -Dfirst-boot-set-hostname=disabled"
14PACKAGECONFIG[first-boot-set-mac] = "-Dfirst-boot-set-mac=enabled, -Dfirst-boot-set-mac=disabled"
15PACKAGECONFIG[http-redirect-awk] = "-Dhttp-redirect=enabled, -Dhttp-redirect=disabled"
16PACKAGECONFIG[usb-ctrl] = "-Dusb-ctrl=enabled, -Dusb-ctrl=disabled"
17PV = "1.0+git${SRCPV}"
18PR = "r1"
19
20SRC_URI = "git://github.com/openbmc/phosphor-misc;branch=master;protocol=https"
21
22S = "${WORKDIR}/git"
23SYSTEMD_PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
24SYSTEMD_SERVICE:${PN}-first-boot-set-hostname = "first-boot-set-hostname.service"
25SYSTEMD_SERVICE:${PN}-first-boot-set-mac = "first-boot-set-mac@.service"
26SYSTEMD_SERVICE:${PN}-http-redirect-awk = " \
27    http-redirect@.service \
28    http-redirect.socket \
29    "
30
31inherit meson
32inherit pkgconfig
33inherit systemd
34
35PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
36
37RDEPENDS:${PN}-http-redirect-awk = "${VIRTUAL-RUNTIME_base-utils}"
38RDEPENDS:${PN}-first-boot-set-hostname += "bash"
39RDEPENDS:${PN}-first-boot-set-mac += "bash"
40RDEPENDS:${PN}-usb-ctrl += "bash"
41
42# first-boot-set-hostname
43FILES:${PN}-first-boot-set-hostname = "${bindir}/first-boot-set-hostname.sh"
44# first-boot-set-mac
45FILES:${PN}-first-boot-set-mac = "${bindir}/first-boot-set-mac.sh"
46# http-redirect-awk
47FILES:${PN}-http-redirect-awk = "${bindir}/http-redirect.awk"
48# usb-ctrl
49FILES:${PN}-usb-ctrl = "${bindir}/usb-ctrl"
50
51PHOSPHOR_MISC_PACKAGES = " \
52    ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-hostname', '${PN}-first-boot-set-hostname', '', d)} \
53    ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-mac', '${PN}-first-boot-set-mac', '', d)} \
54    ${@bb.utils.contains('PACKAGECONFIG', 'http-redirect-awk', '${PN}-http-redirect-awk', '', d)} \
55    ${@bb.utils.contains('PACKAGECONFIG', 'usb-ctrl', '${PN}-usb-ctrl', '', d)} \
56    "
57PACKAGE_BEFORE_PN += "${PHOSPHOR_MISC_PACKAGES}"
58