xref: /openbmc/openbmc/meta-openpower/recipes-phosphor/host/p9-host-start.bb (revision 91a1cec28e08f949b120fe8885e87ef256ca4d93)
1SUMMARY = "POWER9 start host"
2DESCRIPTION = "Service to start POWER9 IPL through SBE"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit obmc-phosphor-systemd
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
10
11PROVIDES += 'virtual/obmc-host-ctl'
12RPROVIDES:${PN} += 'virtual-obmc-host-ctl'
13
14RDEPENDS:${PN} += "op-proc-control \
15                   op-proc-control-systemd-links"
16
17S = "${WORKDIR}/sources"
18UNPACKDIR = "${S}"
19
20TMPL = "start_host@.service"
21INSTFMT = "start_host@{0}.service"
22TGTFMT = "obmc-host-startmin@{0}.target"
23FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
24
25SYSTEMD_SERVICE:${PN} += "${TMPL}"
26SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
27