1SUMMARY = "Import::Into - import packages into other packages"
2DESCRIPTION = "Writing exporters is a pain. Some use \"Exporter\", some use \
3\"Sub::Exporter\", some use \"Moose::Exporter\", some use \
4\"Exporter::Declare\"... and some things are pragmas.\
5\
6Exporting on someone else's behalf is harder. The exporters don't provide a \
7consistent API for this, and pragmas need to have their import method called \
8directly, since they effect the current unit of compilation. \
9\
10\"Import::Into\" provides global methods to make this painless."
11
12SECTION = "libs"
13
14HOMEPAGE = "https://metacpan.org/pod/Import::Into"
15
16LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
17LIC_FILES_CHKSUM = "file://README;beginline=209;endline=223;md5=3cf363f1e405dea6db2c6cd0ef23680c"
18
19SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Import-Into-${PV}.tar.gz"
20SRC_URI[sha256sum] = "decb259bc2ff015fe3dac85e4a287d4128e9b0506a0b2c5fa7244836a68b1084"
21
22S = "${WORKDIR}/Import-Into-${PV}"
23
24inherit cpan
25
26RDEPENDS:${PN} = " libmodule-runtime-perl \
27                   perl-module-strict \
28                   perl-module-warnings \
29"
30
31BBCLASSEXTEND = "native"
32