xref: /openbmc/openbmc/meta-openembedded/meta-oe/recipes-support/bcu/bcu_1.1.100.bb (revision 8460358c3d24c71d9d38fd126c745854a6301564)
1SUMMARY = "NXP Board Control Utilities"
2DESCRIPTION = "The NXP Board Control Utilities are able to control various \
3               features of NXP i.MX evaluation boards (EVK) from a host \
4               computer. \
5               Features like resetting the board, selecting the boot mode, \
6               monitoring power consumption, programming the EEPROM and others"
7HOMEPAGE = "https://github.com/nxp-imx/bcu"
8SECTION = "devel"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=884d48c2aa7b82e1ad4a33909fab24b6"
11
12SRC_URI = "git://github.com/nxp-imx/bcu;protocol=https;branch=master \
13           file://0001-CMakeLists-do-not-use-vendored-libcurl.patch \
14           "
15SRCREV = "c34d89b29f3d0d12793cd78b194d2f1d11728baf"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "curl libyaml libusb1 openssl libftdi"
20
21inherit cmake pkgconfig
22
23BBCLASSEXTEND = "native nativesdk"
24