xref: /openbmc/openbmc/meta-openembedded/meta-oe/recipes-navigation/geoclue/geoclue_2.7.2.bb (revision 8460358c3d24c71d9d38fd126c745854a6301564)
1SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPL-2.0-or-later"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala
14
15SRCREV = "ab0a7a447ac037d5043aa04df3030796bf47d94d"
16SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;branch=master \
17    file://0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch \
18"
19
20S = "${WORKDIR}/git"
21
22# Without this line, package is declared a library and named libgeoclue*
23AUTO_LIBNAME_PKGS = ""
24
25PACKAGECONFIG ??= "3g modem-gps cdma nmea lib agent"
26PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
27PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
28PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
29PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon"
30PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false"
31PACKAGECONFIG[agent] = "-Ddemo-agent=true,-Ddemo-agent=false,libnotify"
32
33GTKDOC_MESON_OPTION = "gtk-doc"
34
35EXTRA_OEMESON += " \
36    -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
37"
38
39FILES:${PN} += " \
40    ${datadir}/dbus-1/system-services \
41    ${datadir}/polkit-1/rules.d \
42    ${libdir} \
43    ${systemd_unitdir} \
44    ${prefix}/libexec \
45"
46
47FILES:${PN}-dev += " \
48    ${datadir}/dbus-1/interfaces \
49    ${datadir}/gir-1.0 \
50"
51