1# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14DESCRIPTION = "\
15open-vm-tools is a set of services and modules that enable several features in VMware products \
16for better management of and seamless user interactions with guests.\
17"
18SECTION = "vmware-tools"
19
20LICENSE = "LGPL-2.0-only & GPL-2.0-only & BSD-2-Clause & CDDL-1.0"
21LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
22LICENSE:modules/freebsd/vmblock = "BSD-2-Clause"
23LICENSE:modules/freebsd/vmmemctl = "GPL-2.0-only"
24LICENSE:modules/freebsd/vmxnet = "GPL-2.0-only"
25LICENSE:modules/linux = "GPL-2.0-only"
26LICENSE:modules/solaris = "CDDL-1.0"
27
28SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=stable-12.5.x \
29           file://tools.conf \
30           file://vmtoolsd.service \
31           file://vmtoolsd.init \
32           file://0001-configure.ac-don-t-use-dnet-config.patch;patchdir=.. \
33           file://0002-Use-configure-test-for-struct-timespec.patch;patchdir=.. \
34           file://0003-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch;patchdir=.. \
35           file://0004-Use-configure-to-test-for-feature-instead-of-platfor.patch;patchdir=.. \
36           file://0005-Use-configure-test-for-sys-stat.h-include.patch;patchdir=.. \
37           file://0006-Fix-subdir-objects-configure-error.patch;patchdir=.. \
38           file://0007-include-poll.h-instead-of-sys-poll.h.patch;patchdir=.. \
39           file://0008-Rename-poll.h-to-vm_poll.h.patch;patchdir=.. \
40           file://0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch;patchdir=.. \
41           file://0010-Use-uintmax_t-for-handling-rlim_t.patch;patchdir=.. \
42           file://0011-Use-off64_t-instead-of-__off64_t.patch;patchdir=.. \
43           file://0012-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \
44           file://0013-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \
45           file://0014-timeSync-Portable-way-to-print-64bit-time_t.patch;patchdir=.. \
46           "
47
48UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)"
49
50SRC_URI:append:libc-musl = " file://0001-Add-resolv_compat.h-for-musl-builds.patch;patchdir=.. \
51"
52
53SRCREV = "f2ca37ef3510543172657b82493d1eceefa9a134"
54
55S = "${WORKDIR}/git/open-vm-tools"
56
57DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc"
58
59# open-vm-tools is supported only on x86.
60COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
61
62inherit autotools pkgconfig systemd update-rc.d
63
64SYSTEMD_SERVICE:${PN} = "vmtoolsd.service"
65
66EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
67         --disable-tests --without-gtkmm --without-pam \
68         --disable-vgauth --disable-deploypkg --disable-containerinfo \
69         --without-root-privileges --without-kernel-modules --with-tirpc \
70         --with-udev-rules-dir=${nonarch_base_libdir}/udev/rules.d"
71
72NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
73X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
74PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
75
76# fuse gets implicitly detected; there is no --without-fuse option.
77PACKAGECONFIG[fuse] = ",,fuse"
78
79CFLAGS:append:toolchain-clang = " -Wno-address-of-packed-member -Wno-error=unused-function"
80FILES:${PN} += "\
81    ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
82    ${libdir}/open-vm-tools/plugins/common/lib*.so \
83    ${sysconfdir}/vmware-tools/tools.conf \
84"
85FILES:${PN}-locale += "${datadir}/open-vm-tools/messages"
86FILES:${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
87
88CONFFILES:${PN} += "${sysconfdir}/vmware-tools/tools.conf"
89
90RDEPENDS:${PN} = "util-linux libdnet fuse"
91
92do_install:append() {
93    if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
94        install -d ${D}/sbin
95        ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
96    fi
97    install -d ${D}${sysconfdir}/vmware-tools
98    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
99        install -d ${D}${systemd_unitdir}/system
100        install -m 644 ${UNPACKDIR}/*.service ${D}${systemd_unitdir}/system
101    else
102        install -d ${D}${sysconfdir}/init.d
103        install -m 0755 ${UNPACKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
104    fi
105    install -m 0644 ${UNPACKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
106}
107
108do_configure:prepend() {
109    export CUSTOM_DNET_NAME=dnet
110    export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
111}
112
113INITSCRIPT_PACKAGES = "${PN}"
114INITSCRIPT_NAME:${PN} = "vmtoolsd"
115INITSCRIPT_PARAMS:${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
116
117python() {
118    if 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
119        raise bb.parse.SkipRecipe('Requires meta-filesystems to be present to provide fuse.')
120}
121
122CVE_PRODUCT = "open-vm-tools vmware:tools"
123CVE_STATUS[CVE-2014-4199] = "fixed-version: No action required. The current version (12.3.5) is not affected by the CVE which affects version 10.0.3"
124CVE_STATUS[CVE-2014-4200] = "fixed-version: No action required. The current version (12.3.5) is not affected by the CVE which affects version 10.0.3"
125