xref: /openbmc/openbmc/meta-openembedded/meta-networking/recipes-support/ipvsadm/ipvsadm_1.31.bb (revision b542dec15d5efd10eecb485af0629315876cebfc)
1e42b3e38SBrad BishopSUMMARY = "Linux Virtual Server administration Utility"
2e42b3e38SBrad BishopHOMEPAGE = "http://www.linux-vs.org/software/index.html"
3e42b3e38SBrad BishopDESCRIPTION = "Ipvsadm  is  used  to set up, maintain or inspect the virtual server \
4e42b3e38SBrad Bishoptable in the Linux kernel. The Linux Virtual  Server  can  be  used  to \
5e42b3e38SBrad Bishopbuild  scalable  network  services  based  on  a cluster of two or more nodes. \
6e42b3e38SBrad BishopThe active node of the cluster redirects service requests  to  a \
7e42b3e38SBrad Bishopcollection  of  server  hosts  that will actually perform the services. \
8e42b3e38SBrad BishopSupported features include two protocols (TCP and UDP),  three  packet-forwarding \
9e42b3e38SBrad Bishopmethods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
10e42b3e38SBrad Bishop(round robin, weighted round robin,  least-connec-tion, weighted least-connection, \
11e42b3e38SBrad Bishoplocality-based  least-connection, locality-based least-connection with replication, \
12e42b3e38SBrad Bishopdestination-hashing, and source-hashing)."
13e42b3e38SBrad BishopSECTION = "net"
149aee5003SAndrew GeisslerLICENSE = "GPL-2.0-only"
15e42b3e38SBrad BishopLIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=b4e40069f15598d0e3fe2aa177e5ec77"
16e42b3e38SBrad Bishop
17e42b3e38SBrad BishopDEPENDS += "libnl popt"
18e42b3e38SBrad Bishop
19e42b3e38SBrad BishopSRC_URI = "https://mirrors.edge.kernel.org/pub/linux/utils/kernel/ipvsadm/${BP}.tar.xz \
20e42b3e38SBrad Bishop        file://0001-Modify-the-Makefile-for-cross-compile.patch \
21e42b3e38SBrad Bishop        file://0003-ipvsadm-remove-dependency-on-bash.patch \
22e42b3e38SBrad Bishop        file://makefile-add-ldflags.patch \
23*b542dec1SPatrick Williams        file://0001-Add-CCFLAGS-to-cflags.patch \
24*b542dec1SPatrick Williams        file://0001-libipvs-Include-missing-sys-types.h.patch \
25e42b3e38SBrad Bishop"
26e42b3e38SBrad Bishop
27e42b3e38SBrad BishopSRC_URI[md5sum] = "f6d1707c5baf684b58fd33682d67871f"
28e42b3e38SBrad BishopSRC_URI[sha256sum] = "1a0a5e25b5a1226435d2fb76341656f83a710183aebb0d204db39c0ec3bedfdb"
29e42b3e38SBrad Bishop
30e42b3e38SBrad BishopUPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/ipvsadm"
31e42b3e38SBrad Bishop
32*b542dec1SPatrick WilliamsEXTRA_OEMAKE += "CCFLAGS='${CFLAGS}'"
33*b542dec1SPatrick Williams
34e42b3e38SBrad Bishopdo_compile() {
35*b542dec1SPatrick Williams    oe_runmake all
36e42b3e38SBrad Bishop}
37e42b3e38SBrad Bishop
38e42b3e38SBrad Bishopdo_install() {
39e42b3e38SBrad Bishop    sed -i -e "s;SBIN\t\t= \$(BUILD_ROOT)/sbin;SBIN\t\t= \$(BUILD_ROOT)$base_sbindir;" \
40e42b3e38SBrad Bishop        -e "s;INIT\t\t= \$(BUILD_ROOT)/etc/rc.d/init.d;INIT\t\t= \$(BUILD_ROOT)${sysconfdir}/init.d;" \
41e42b3e38SBrad Bishop        ${S}/Makefile
42e42b3e38SBrad Bishop    oe_runmake 'BUILD_ROOT=${D}' install
43e42b3e38SBrad Bishop}
44e42b3e38SBrad Bishop
45e42b3e38SBrad Bishopinherit pkgconfig
46