xref: /openbmc/openbmc/meta-openembedded/meta-networking/recipes-support/ipvsadm/ipvsadm_1.31.bb (revision b542dec15d5efd10eecb485af0629315876cebfc)
1SUMMARY = "Linux Virtual Server administration Utility"
2HOMEPAGE = "http://www.linux-vs.org/software/index.html"
3DESCRIPTION = "Ipvsadm  is  used  to set up, maintain or inspect the virtual server \
4table in the Linux kernel. The Linux Virtual  Server  can  be  used  to \
5build  scalable  network  services  based  on  a cluster of two or more nodes. \
6The active node of the cluster redirects service requests  to  a \
7collection  of  server  hosts  that will actually perform the services. \
8Supported features include two protocols (TCP and UDP),  three  packet-forwarding \
9methods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
10(round robin, weighted round robin,  least-connec-tion, weighted least-connection, \
11locality-based  least-connection, locality-based least-connection with replication, \
12destination-hashing, and source-hashing)."
13SECTION = "net"
14LICENSE = "GPL-2.0-only"
15LIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=b4e40069f15598d0e3fe2aa177e5ec77"
16
17DEPENDS += "libnl popt"
18
19SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/utils/kernel/ipvsadm/${BP}.tar.xz \
20        file://0001-Modify-the-Makefile-for-cross-compile.patch \
21        file://0003-ipvsadm-remove-dependency-on-bash.patch \
22        file://makefile-add-ldflags.patch \
23        file://0001-Add-CCFLAGS-to-cflags.patch \
24        file://0001-libipvs-Include-missing-sys-types.h.patch \
25"
26
27SRC_URI[md5sum] = "f6d1707c5baf684b58fd33682d67871f"
28SRC_URI[sha256sum] = "1a0a5e25b5a1226435d2fb76341656f83a710183aebb0d204db39c0ec3bedfdb"
29
30UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/ipvsadm"
31
32EXTRA_OEMAKE += "CCFLAGS='${CFLAGS}'"
33
34do_compile() {
35    oe_runmake all
36}
37
38do_install() {
39    sed -i -e "s;SBIN\t\t= \$(BUILD_ROOT)/sbin;SBIN\t\t= \$(BUILD_ROOT)$base_sbindir;" \
40        -e "s;INIT\t\t= \$(BUILD_ROOT)/etc/rc.d/init.d;INIT\t\t= \$(BUILD_ROOT)${sysconfdir}/init.d;" \
41        ${S}/Makefile
42    oe_runmake 'BUILD_ROOT=${D}' install
43}
44
45inherit pkgconfig
46