xref: /openbmc/openbmc/meta-ibm/meta-system1/recipes-phosphor/flash/bios-version.bb (revision fc75d9618b2f87729a965717ebde75a1612f4c82)
1SUMMARY = "YAML configuration for IBM System1"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
10
11RDEPENDS:${PN} += "bash flashrom"
12
13SRC_URI += " \
14    file://bios-version.sh \
15    file://bios-version.service \
16    file://pch-standby.service \
17    file://pch-standby-check.sh \
18    "
19
20do_install:append() {
21    install -d ${D}${libexecdir}
22    install -m 0755 ${UNPACKDIR}/bios-version.sh ${D}${libexecdir}/
23    install -m 0755 ${UNPACKDIR}/pch-standby-check.sh ${D}${libexecdir}/
24
25    install -d ${D}${systemd_system_unitdir}
26    install -m 0644 ${UNPACKDIR}/bios-version.service ${D}${systemd_system_unitdir}/
27    install -m 0644 ${UNPACKDIR}/pch-standby.service ${D}${systemd_system_unitdir}/
28}
29
30SYSTEMD_SERVICE:${PN} += "bios-version.service"
31SYSTEMD_SERVICE:${PN} += "pch-standby.service"
32
33FILES:${PN} += "${systemd_system_unitdir}/bios-version.service ${libexecdir}/bios-version.sh"
34FILES:${PN} += "${systemd_system_unitdir}/pch-standby.service ${libexecdir}/pch-standby-check.sh"
35
36