/openbmc/linux/drivers/gpu/drm/gud/ |
H A D | gud_connector.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
/openbmc/linux/drivers/gpu/drm/nouveau/dispnv04/ |
H A D | tvnv17.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
/openbmc/linux/drivers/gpu/drm/i2c/ |
H A D | ch7006_drv.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
/openbmc/linux/drivers/gpu/drm/vc4/ |
H A D | vc4_vec.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
/openbmc/linux/drivers/gpu/drm/i915/display/ |
H A D | intel_tv.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
/openbmc/linux/drivers/gpu/drm/ |
H A D | drm_atomic_uapi.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
H A D | drm_connector.c | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|
/openbmc/linux/include/drm/ |
H A D | drm_connector.h | diff 1fd4a5a36f9f10aaad5d9b1b329c2c057d80a0e5 Thu Nov 17 03:28:45 CST 2022 Maxime Ripard <maxime@cerno.tech> drm/connector: Rename legacy TV property
The current tv_mode has driver-specific values that don't allow to easily share code using it, either at the userspace or kernel level.
Since we're going to introduce a new, generic, property that fit the same purpose, let's rename this one to legacy_tv_mode to make it obvious we should move away from it.
Acked-by: Thomas Zimmermann <tzimmermann@suse.de> Reviewed-by: Lyude Paul <lyude@redhat.com> # nouveau Reviewed-by: Noralf Trønnes <noralf@tronnes.org> Tested-by: Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com> Acked-in-principle-or-something-like-that-by: Daniel Vetter <daniel.vetter@ffwll.ch> Link: https://lore.kernel.org/r/20220728-rpi-analog-tv-properties-v10-2-256dad125326@cerno.tech Signed-off-by: Maxime Ripard <maxime@cerno.tech>
|