Revision tags: v00.04.15, v00.04.14, v00.04.13, v00.04.12, v00.04.11, v00.04.10, v00.04.09, v00.04.08, v00.04.07, v00.04.06, v00.04.05, v00.04.04, v00.04.03, v00.04.02, v00.04.01, v00.04.00, v2021.04, v00.03.03, v2021.01, v2020.10, v2020.07, v00.02.13, v2020.04, v2020.01, v2019.10, v00.02.05, v00.02.04, v00.02.03, v00.02.02, v00.02.01, v2019.07, v00.02.00, v2019.04, v2018.07 |
|
#
83d290c5 |
| 06-May-2018 |
Tom Rini <trini@konsulko.com> |
SPDX: Convert all of our single license tags to Linux Kernel style
When U-Boot started using SPDX tags we were among the early adopters and there weren't a lot of other examples to borrow from. So
SPDX: Convert all of our single license tags to Linux Kernel style
When U-Boot started using SPDX tags we were among the early adopters and there weren't a lot of other examples to borrow from. So we picked the area of the file that usually had a full license text and replaced it with an appropriate SPDX-License-Identifier: entry. Since then, the Linux Kernel has adopted SPDX tags and they place it as the very first line in a file (except where shebangs are used, then it's second line) and with slightly different comment styles than us.
In part due to community overlap, in part due to better tag visibility and in part for other minor reasons, switch over to that style.
This commit changes all instances where we have a single declared license in the tag as both the before and after are identical in tag contents. There's also a few places where I found we did not have a tag and have introduced one.
Signed-off-by: Tom Rini <trini@konsulko.com>
show more ...
|
#
d024236e |
| 18-Apr-2018 |
Tom Rini <trini@konsulko.com> |
Remove unnecessary instances of DECLARE_GLOBAL_DATA_PTR
We have a large number of places where while we historically referenced gd in the code we no longer do, as well as cases where the code added
Remove unnecessary instances of DECLARE_GLOBAL_DATA_PTR
We have a large number of places where while we historically referenced gd in the code we no longer do, as well as cases where the code added that line "just in case" during development and never dropped it.
Signed-off-by: Tom Rini <trini@konsulko.com>
show more ...
|
Revision tags: v2018.03, v2018.01, v2017.11 |
|
#
4d1c166f |
| 01-Oct-2017 |
Tom Rini <trini@konsulko.com> |
Merge git://git.denx.de/u-boot-usb
|
#
f4d4f7d4 |
| 01-Oct-2017 |
Bin Meng <bmeng.cn@gmail.com> |
test: dm: usb: Update test cases for USB
Now that we have changed to remove all devices under the root hub in usb_stop(), and corrected the USB emulator select logic, it makes no sense to do various
test: dm: usb: Update test cases for USB
Now that we have changed to remove all devices under the root hub in usb_stop(), and corrected the USB emulator select logic, it makes no sense to do various tests based on 'usb tree' output since the order of devices is no longer fixed. Remove these USB test cases related to 'usb tree'.
For the USB remove test, ideally we should remove an emulator device node from the device tree, but this is so far not working. Change to test the 'usb stop' only.
Signed-off-by: Bin Meng <bmeng.cn@gmail.com>
show more ...
|
Revision tags: v2016.07, openbmc-20160624-1 |
|
#
88033d73 |
| 14-Mar-2016 |
Tom Rini <trini@konsulko.com> |
Merge git://git.denx.de/u-boot-dm
|
#
61ccd886 |
| 29-Feb-2016 |
Simon Glass <sjg@chromium.org> |
dm: usb: Clean up USB after each test
The USB subsystem has a few counters that need to be reset since they are stored in static variables rather than driver-model data. An example is usb_max_devs.
dm: usb: Clean up USB after each test
The USB subsystem has a few counters that need to be reset since they are stored in static variables rather than driver-model data. An example is usb_max_devs. Ultimately we should move this data into the USB uclass.
For now, make sure that USB is reset after each test, so that the counters go back to zero.
Note: this is not a perfect solution: It a USB test fails it will exit immediately and leave USB un-reset. The impact here is that it may cause subsequence test failures in the same run.
Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
2a981dc2 |
| 29-Feb-2016 |
Simon Glass <sjg@chromium.org> |
dm: block: Adjust device calls to go through helpers function
To ease conversion to driver model, add helper functions which deal with calling each block device method. With driver model we can reim
dm: block: Adjust device calls to go through helpers function
To ease conversion to driver model, add helper functions which deal with calling each block device method. With driver model we can reimplement these functions with the same arguments.
Use inline functions to avoid increasing code size on some boards.
Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-by: Bin Meng <bmeng.cn@gmail.com> Tested-by: Stephen Warren <swarren@nvidia.com>
show more ...
|
#
ebac37cf |
| 29-Feb-2016 |
Simon Glass <sjg@chromium.org> |
dm: blk: Rename get_device() to blk_get_device_by_str()
The current name is too generic. The function returns a block device based on a provided string. Rename it to aid searching and make its purpo
dm: blk: Rename get_device() to blk_get_device_by_str()
The current name is too generic. The function returns a block device based on a provided string. Rename it to aid searching and make its purpose clearer. Also add a few comments.
Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-by: Bin Meng <bmeng.cn@gmail.com> Tested-by: Stephen Warren <swarren@nvidia.com>
show more ...
|
#
4101f687 |
| 29-Feb-2016 |
Simon Glass <sjg@chromium.org> |
dm: Drop the block_dev_desc_t typedef
Use 'struct' instead of a typdef. Also since 'struct block_dev_desc' is long and causes 80-column violations, rename it to struct blk_desc.
Signed-off-by: Simo
dm: Drop the block_dev_desc_t typedef
Use 'struct' instead of a typdef. Also since 'struct block_dev_desc' is long and causes 80-column violations, rename it to struct blk_desc.
Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-by: Bin Meng <bmeng.cn@gmail.com> Tested-by: Stephen Warren <swarren@nvidia.com>
show more ...
|
#
7c4213f6 |
| 07-Dec-2015 |
Stephen Warren <swarren@nvidia.com> |
block: pass block dev not num to read/write/erase()
This will allow the implementation to make use of data in the block_dev structure beyond the base device number. This will be useful so that eMMC
block: pass block dev not num to read/write/erase()
This will allow the implementation to make use of data in the block_dev structure beyond the base device number. This will be useful so that eMMC block devices can encompass the HW partition ID rather than treating this out-of-band. Equally, the existence of the priv field is crying out for this patch to exist.
Signed-off-by: Stephen Warren <swarren@nvidia.com> Reviewed-by: Tom Rini <trini@konsulko.com>
show more ...
|
#
a57a8174 |
| 07-Jan-2016 |
Simon Glass <sjg@chromium.org> |
dm: test: usb: Update the USB tests so that they all pass
Due to a limitation removed in an earlier patch, USB tests were not seeing all the devices. Update the tests to pass now that all devices ar
dm: test: usb: Update the USB tests so that they all pass
Due to a limitation removed in an earlier patch, USB tests were not seeing all the devices. Update the tests to pass now that all devices are visible.
Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
Revision tags: v2016.01-rc1 |
|
#
bff1a71e |
| 09-Nov-2015 |
Simon Glass <sjg@chromium.org> |
dm: test: usb: sandbox: Add keyboard tests for sandbox
Add a test that verifies that USB keyboards work correctly on sandbox. This verifies some additional parts of the USB stack.
Signed-off-by: Si
dm: test: usb: sandbox: Add keyboard tests for sandbox
Add a test that verifies that USB keyboards work correctly on sandbox. This verifies some additional parts of the USB stack.
Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
cd716372 |
| 09-Nov-2015 |
Simon Glass <sjg@chromium.org> |
dm: test: usb: Add a test for device reordering
Add tests that 'usb tree' produces the right output when a device changes order on the bus.
Signed-off-by: Simon Glass <sjg@chromium.org>
|
#
431cbd6d |
| 09-Nov-2015 |
Simon Glass <sjg@chromium.org> |
dm: test: usb: Add tests for the 'usb tree' command
Add tests that this command produces the right output, even when a rescan results in a device disappearing from the bus.
Signed-off-by: Simon Gla
dm: test: usb: Add tests for the 'usb tree' command
Add tests that this command produces the right output, even when a rescan results in a device disappearing from the bus.
Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
24b852a7 |
| 09-Nov-2015 |
Simon Glass <sjg@chromium.org> |
Move console definitions into a new console.h file
The console includes a global variable and several functions that are only used by a small subset of U-Boot files. Before adding more functions, mo
Move console definitions into a new console.h file
The console includes a global variable and several functions that are only used by a small subset of U-Boot files. Before adding more functions, move the definitions into their own header file.
Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
3884c98c |
| 09-Nov-2015 |
Simon Glass <sjg@chromium.org> |
dm: usb: Avoid time delays in sandbox tests
Currently the USB tests take around two seconds to run. Remove these unnecessary time delays so that the tests run quickly.
Signed-off-by: Simon Glass <s
dm: usb: Avoid time delays in sandbox tests
Currently the USB tests take around two seconds to run. Remove these unnecessary time delays so that the tests run quickly.
Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
Revision tags: v2015.10, v2015.10-rc5, v2015.10-rc4, v2015.10-rc3, v2015.10-rc2, v2015.10-rc1, v2015.07, v2015.07-rc3, v2015.07-rc2 |
|
#
e721b882 |
| 20-May-2015 |
Joe Hershberger <joe.hershberger@ni.com> |
test: Generalize the unit test framework
Separate the ability to define tests and assert status of test functions from the dm tests so they can be used more consistently throughout all tests.
Signe
test: Generalize the unit test framework
Separate the ability to define tests and assert status of test functions from the dm tests so they can be used more consistently throughout all tests.
Signed-off-by: Joe Hershberger <joe.hershberger@ni.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
Revision tags: v2015.07-rc1 |
|
#
b939689c |
| 05-May-2015 |
Albert ARIBAUD <albert.u.boot@aribaud.net> |
Merge branch 'u-boot/master' into 'u-boot-arm/master'
|
Revision tags: v2015.04, v2015.04-rc5 |
|
#
e00cb223 |
| 25-Mar-2015 |
Simon Glass <sjg@chromium.org> |
dm: usb: Add tests for the USB uclass
This adds a simple test for probing and a functional test using the flash stick emulator, which tests a large chunk of the USB stack.
Signed-off-by: Simon Glas
dm: usb: Add tests for the USB uclass
This adds a simple test for probing and a functional test using the flash stick emulator, which tests a large chunk of the USB stack.
Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-by: Marek Vasut <marex@denx.de>
show more ...
|