Revision tags: v00.04.15, v00.04.14, v00.04.13, v00.04.12, v00.04.11, v00.04.10, v00.04.09, v00.04.08, v00.04.07, v00.04.06, v00.04.05, v00.04.04, v00.04.03, v00.04.02, v00.04.01, v00.04.00, v2021.04, v00.03.03, v2021.01, v2020.10, v2020.07, v00.02.13, v2020.04, v2020.01, v2019.10, v00.02.05, v00.02.04, v00.02.03, v00.02.02, v00.02.01, v2019.07, v00.02.00, v2019.04 |
|
#
89aa19d0 |
| 11-Sep-2018 |
Tom Rini <trini@konsulko.com> |
Merge tag 'fpga-for-v2018.11' of git://git.denx.de/u-boot-microblaze
FPGA changes for v2018.11
- add fpga tests to cover fpga commands - fpga Kconfig cleanup - fix cmd/fpga.c - add support for miss
Merge tag 'fpga-for-v2018.11' of git://git.denx.de/u-boot-microblaze
FPGA changes for v2018.11
- add fpga tests to cover fpga commands - fpga Kconfig cleanup - fix cmd/fpga.c - add support for missing fpga loadmk commands - add fpga fragment to MAINTAINERS
show more ...
|
Revision tags: v2018.07 |
|
#
b5d19a93 |
| 05-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Fix loads command
Convert last loads command to fpga subcommands.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
|
#
a2d1033b |
| 05-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Use CMD_RET_FAILURE instead of simple 1
Use standard return command failure macro.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
|
#
8c75f794 |
| 26-Jul-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Add support for missing fpga loadmk commands
There are ways how to call fpga loadmk
1. Full command fpga loadmk [dev] [address]
2. Dev setup via variable set fpga [dev] fpga loadmk [add
cmd: fpga: Add support for missing fpga loadmk commands
There are ways how to call fpga loadmk
1. Full command fpga loadmk [dev] [address]
2. Dev setup via variable set fpga [dev] fpga loadmk [address]
3. Address setup via variable set fpgadata [address] fpga loadmk [dev]
4. Dev and address setup via variables set fpga [dev] set fpgadata [address] fpga loadmk
Before this patch only cases 1 and 3 are working but the part of code was trying to support also cases 2 and 4. This patch is adding support for cases 2 and 4 to have all of combinations supported.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
2892fe80 |
| 04-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Fix loadmk command
Convert loadmk command to fpga subcommands. Not all combinations are working but they have never worked properly. This will be fixed later.
Signed-off-by: Michal Simek
cmd: fpga: Fix loadmk command
Convert loadmk command to fpga subcommands. Not all combinations are working but they have never worked properly. This will be fixed later.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
49503f9a |
| 04-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Fix loadfs command
Convert loadfs command to fpga subcommands.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
|
#
85754795 |
| 04-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Fix dump and all direct fpga load commands
Separate dump, load, loadb, loadp and loadbp commands to separate functions to make it clear how they are called and what parameters they need.
cmd: fpga: Fix dump and all direct fpga load commands
Separate dump, load, loadb, loadp and loadbp commands to separate functions to make it clear how they are called and what parameters they need.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
f4c7a4ae |
| 04-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Extract fpga info command to separate function
Move fpga info to U_BOOT_CMD_MKENT subcommand. Also use strtol instead of simple_strtoul. The reason is that if -1 is passed (or fpga info w
cmd: fpga: Extract fpga info command to separate function
Move fpga info to U_BOOT_CMD_MKENT subcommand. Also use strtol instead of simple_strtoul. The reason is that if -1 is passed (or fpga info without "fpga" variable) the list of all fpgas is shown. This functionality is in the fpga core but it couldn't be performed.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
9657d97c |
| 04-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Create new do_fpga_wrapper for using u-boot subcommands
Create command wrapper to clean fpga subcommands. The function logic is taken from cmd_dm.c
Signed-off-by: Michal Simek <michal.si
cmd: fpga: Create new do_fpga_wrapper for using u-boot subcommands
Create command wrapper to clean fpga subcommands. The function logic is taken from cmd_dm.c
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
5cadab60 |
| 30-May-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Clean wrong_parms handling
There is no reason to check parameters in separate switch. Check them directly when they are read. Also there is no reason to check loadmk case separately becau
cmd: fpga: Clean wrong_parms handling
There is no reason to check parameters in separate switch. Check them directly when they are read. Also there is no reason to check loadmk case separately because fpga_data address must be non zero too.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
aa93ac59 |
| 04-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Remove parameter checking from fpga loadfs command
Parameter checking is dead code because all the time there must be all params assigned. If they are not assigned there is no 9th paramet
cmd: fpga: Remove parameter checking from fpga loadfs command
Parameter checking is dead code because all the time there must be all params assigned. If they are not assigned there is no 9th parameters passed and checking before return CMD_RET_USAGE.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
44d839bd |
| 30-May-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Move parameter checking for loadfs/loads
There is no reason to check parameters in separate switch before main one. This patch is simplifying error path and checking parameters right afte
cmd: fpga: Move parameter checking for loadfs/loads
There is no reason to check parameters in separate switch before main one. This patch is simplifying error path and checking parameters right after assignment.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
ccd65203 |
| 30-May-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Cleanup error handling in connection to FPGA_NONE
Incorrect command is already handled and FPGA_NONE should be used only one. In case of error CMD_RET_USAGE can be returned directly witho
cmd: fpga: Cleanup error handling in connection to FPGA_NONE
Incorrect command is already handled and FPGA_NONE should be used only one. In case of error CMD_RET_USAGE can be returned directly without any addition logic around.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
323fe38e |
| 30-May-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Move fpga_get_op to avoid local function declaration
Move fpga_get_op() to top of file to remove local function declaration and also remove useless retyping.
Signed-off-by: Michal Simek
cmd: fpga: Move fpga_get_op to avoid local function declaration
Move fpga_get_op() to top of file to remove local function declaration and also remove useless retyping.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
55010969 |
| 30-May-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Move error handling to do_fpga()
Clean fpga_get_op() error handling by moving checking/print to do_fpga.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <s
cmd: fpga: Move error handling to do_fpga()
Clean fpga_get_op() error handling by moving checking/print to do_fpga.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
3cc97164 |
| 05-Jun-2018 |
Michal Simek <michal.simek@xilinx.com> |
cmd: fpga: Remove fit image support passed without fpga device
The patch applied in 2010 "cmd_fpga: cleanup help and check parameters" (sha1: a790b5b2326be9d7c9ad9e3d9b51a8bfabc62d07" was adding thi
cmd: fpga: Remove fit image support passed without fpga device
The patch applied in 2010 "cmd_fpga: cleanup help and check parameters" (sha1: a790b5b2326be9d7c9ad9e3d9b51a8bfabc62d07" was adding this checking
+ if (dev == FPGA_INVALID_DEVICE) { + puts("FPGA device not specified\n"); + op = FPGA_NONE; + }
which simply broke one command flow which was setenv fpga <dev> fpga loadmk <addr> // legacy image fpga loadmk <addr>:<fit_image_name> //fit image
Also this sequence for FIT image is completely broken setenv fpga <dev> setenv fpgadata <addr>:<fit_image_name> fpga loadmk (Note: For legacy images this is working fine).
even from code I don't think this has ever worked properly for fit image (dev = FPGA_INVALID_DEVICE should be rejected by fpga core). Fit image support was in 2008 added by: "[new uImage] Add new uImage fromat support to fpga command" (sha1: c28c4d193dbfb20b2dd3a5447640fd6de7fd0720)
Just a summary of these facts that none found this for pretty long time it shouldn't be a problem to remove this flow (without fpga dev) completely to simplify the code.
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Reviewed-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
582d97b6 |
| 01-Jun-2018 |
Tom Rini <trini@konsulko.com> |
Merge tag 'xilinx-for-v2018.07-2' of git://www.denx.de/git/u-boot-microblaze
Xilinx changes for v2018.07 second pull
zynqmp: - Show reset reason - Remove emulation platform - Update pmufw version -
Merge tag 'xilinx-for-v2018.07-2' of git://www.denx.de/git/u-boot-microblaze
Xilinx changes for v2018.07 second pull
zynqmp: - Show reset reason - Remove emulation platform - Update pmufw version - Simplify mmc bootmode - Remove dc2 useless configuration file - Cleanup mini config - Defconfig syncup - zcu100, zcu104 and zcu111 dts fixes
xilinx: - Use live-tree functions in some drivers - Add support for Avnet Minized and Antminer S9
fpga: - Add secure bitstream loading support
mmc: - Add hs200 mode support
usb xhci: - Header fix
show more ...
|
#
cedd48e2 |
| 31-May-2018 |
Siva Durga Prasad Paladugu <siva.durga.paladugu@xilinx.com> |
cmd: fpga: Add support to load secure bitstreams
This patch adds support to load secure bitstreams(authenticated or encrypted or both). As of now, this feature is added and tested only for xilinx bi
cmd: fpga: Add support to load secure bitstreams
This patch adds support to load secure bitstreams(authenticated or encrypted or both). As of now, this feature is added and tested only for xilinx bitstreams and the secure bitstream was generated using xilinx bootgen tool, but the command is defined in more generic way.
Command example to load authenticated and device key encrypted bitstream is as follows "fpga loads 0 100000 2000000 0 1"
Signed-off-by: Siva Durga Prasad Paladugu <siva.durga.paladugu@xilinx.com> Signed-off-by: Michal Simek <michal.simek@xilinx.com>
show more ...
|
#
f5953610 |
| 31-May-2018 |
Siva Durga Prasad Paladugu <siva.durga.paladugu@xilinx.com> |
cmd: fpga: Reorder the arguments parsing code
This patch modifies the arguments parsing code by parsing based on requested operation for fpga loadfs and then parses the most common/basic args for ot
cmd: fpga: Reorder the arguments parsing code
This patch modifies the arguments parsing code by parsing based on requested operation for fpga loadfs and then parses the most common/basic args for other fpga load commands. This makes it easy for new command extensions or additions especially the commands with more args.
Signed-off-by: Siva Durga Prasad Paladugu <siva.durga.paladugu@xilinx.com> Signed-off-by: Michal Simek <michal.simek@xilinx.com>
show more ...
|
#
83d290c5 |
| 06-May-2018 |
Tom Rini <trini@konsulko.com> |
SPDX: Convert all of our single license tags to Linux Kernel style
When U-Boot started using SPDX tags we were among the early adopters and there weren't a lot of other examples to borrow from. So
SPDX: Convert all of our single license tags to Linux Kernel style
When U-Boot started using SPDX tags we were among the early adopters and there weren't a lot of other examples to borrow from. So we picked the area of the file that usually had a full license text and replaced it with an appropriate SPDX-License-Identifier: entry. Since then, the Linux Kernel has adopted SPDX tags and they place it as the very first line in a file (except where shebangs are used, then it's second line) and with slightly different comment styles than us.
In part due to community overlap, in part due to better tag visibility and in part for other minor reasons, switch over to that style.
This commit changes all instances where we have a single declared license in the tag as both the before and after are identical in tag contents. There's also a few places where I found we did not have a tag and have introduced one.
Signed-off-by: Tom Rini <trini@konsulko.com>
show more ...
|
Revision tags: v2018.03, v2018.01, v2017.11 |
|
#
00caae6d |
| 03-Aug-2017 |
Simon Glass <sjg@chromium.org> |
env: Rename getenv/_f() to env_get()
We are now using an env_ prefix for environment functions. Rename these two functions for consistency. Also add function comments in common.h.
Quite a few place
env: Rename getenv/_f() to env_get()
We are now using an env_ prefix for environment functions. Rename these two functions for consistency. Also add function comments in common.h.
Quite a few places use getenv() in a condition context, provoking a warning from checkpatch. These are fixed up in this patch also.
Suggested-by: Wolfgang Denk <wd@denx.de> Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
#
5b30997f |
| 11-Jan-2017 |
Tom Rini <trini@konsulko.com> |
Merge tag 'xilinx-for-v2017.03' of git://www.denx.de/git/u-boot-microblaze
Xilinx changes for v2017.03
- ATF handoff - DT syncups - gem: Use wait_for_bit(), add simple clk support - Simple clk driv
Merge tag 'xilinx-for-v2017.03' of git://www.denx.de/git/u-boot-microblaze
Xilinx changes for v2017.03
- ATF handoff - DT syncups - gem: Use wait_for_bit(), add simple clk support - Simple clk driver for ZynqMP - Other small changes
show more ...
|
#
5cf22289 |
| 06-Jan-2017 |
Michal Simek <michal.simek@xilinx.com> |
fpga: Use enum for bitstream command types
Using enum simplify handling of different bitstream command types.
Signed-off-by: Michal Simek <michal.simek@xilinx.com>
|
Revision tags: v2016.07, openbmc-20160624-1 |
|
#
19bde031 |
| 27-Jan-2016 |
Tom Rini <trini@konsulko.com> |
Merge branch 'master' of git://www.denx.de/git/u-boot-microblaze
|
#
455ad585 |
| 05-Jan-2016 |
Michal Simek <michal.simek@xilinx.com> |
fpga: Fix compilation warnings
Signed-off-by: Michal Simek <michal.simek@xilinx.com>
|