Revision tags: v00.04.15, v00.04.14, v00.04.13, v00.04.12, v00.04.11, v00.04.10, v00.04.09, v00.04.08, v00.04.07, v00.04.06, v00.04.05, v00.04.04, v00.04.03, v00.04.02, v00.04.01, v00.04.00, v2021.04, v00.03.03, v2021.01, v2020.10, v2020.07, v00.02.13, v2020.04, v2020.01, v2019.10, v00.02.05, v00.02.04, v00.02.03, v00.02.02, v00.02.01, v2019.07, v00.02.00, v2019.04, v2018.07 |
|
#
83d290c5 |
| 06-May-2018 |
Tom Rini <trini@konsulko.com> |
SPDX: Convert all of our single license tags to Linux Kernel style
When U-Boot started using SPDX tags we were among the early adopters and there weren't a lot of other examples to borrow from. So
SPDX: Convert all of our single license tags to Linux Kernel style
When U-Boot started using SPDX tags we were among the early adopters and there weren't a lot of other examples to borrow from. So we picked the area of the file that usually had a full license text and replaced it with an appropriate SPDX-License-Identifier: entry. Since then, the Linux Kernel has adopted SPDX tags and they place it as the very first line in a file (except where shebangs are used, then it's second line) and with slightly different comment styles than us.
In part due to community overlap, in part due to better tag visibility and in part for other minor reasons, switch over to that style.
This commit changes all instances where we have a single declared license in the tag as both the before and after are identical in tag contents. There's also a few places where I found we did not have a tag and have introduced one.
Signed-off-by: Tom Rini <trini@konsulko.com>
show more ...
|
#
9925f1db |
| 01-Apr-2018 |
Alex Kiernan <alex.kiernan@gmail.com> |
net: Move enetaddr env access code to env config instead of net config
In order that we can use eth_env_* even when CONFIG_NET isn't set, move these functions to environment code from net code.
Thi
net: Move enetaddr env access code to env config instead of net config
In order that we can use eth_env_* even when CONFIG_NET isn't set, move these functions to environment code from net code.
This fixes failures such as:
board/ti/am335x/built-in.o: In function `board_late_init': board/ti/am335x/board.c:752: undefined reference to `eth_env_set_enetaddr' u-boot/board/ti/am335x/board.c:766: undefined reference to `eth_env_set_enetaddr'
which caters for use cases such as:
commit f411b5cca48f ("board: am335x: Always set eth/eth1addr environment variable")
when Ethernet is required in Linux, but not U-Boot.
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
show more ...
|
Revision tags: v2018.03, v2018.01, v2017.11 |
|
#
35affd7a |
| 03-Aug-2017 |
Simon Glass <sjg@chromium.org> |
env: Rename eth_getenv_enetaddr() to eth_env_get_enetaddr()
Rename this function for consistency with env_get().
Signed-off-by: Simon Glass <sjg@chromium.org>
|
#
382bee57 |
| 03-Aug-2017 |
Simon Glass <sjg@chromium.org> |
env: Rename setenv() to env_set()
We are now using an env_ prefix for environment functions. Rename setenv() for consistency. Also add function comments in common.h.
Suggested-by: Wolfgang Denk <wd
env: Rename setenv() to env_set()
We are now using an env_ prefix for environment functions. Rename setenv() for consistency. Also add function comments in common.h.
Suggested-by: Wolfgang Denk <wd@denx.de> Signed-off-by: Simon Glass <sjg@chromium.org>
show more ...
|
Revision tags: v2016.07, openbmc-20160624-1, v2016.01-rc1, v2015.10, v2015.10-rc5, v2015.10-rc4, v2015.10-rc3, v2015.10-rc2, v2015.10-rc1, v2015.07, v2015.07-rc3, v2015.07-rc2 |
|
#
062f94f0 |
| 21-May-2015 |
Joe Hershberger <joe.hershberger@ni.com> |
net: Fix a warning added by 76ec988
arm: + lsxhl w+board/buffalo/lsxl/lsxl.c: In function 'rescue_mode': w+board/buffalo/lsxl/lsxl.c:230:8: warning: unused variable 'enetaddr' [-Wunused-variable]
net: Fix a warning added by 76ec988
arm: + lsxhl w+board/buffalo/lsxl/lsxl.c: In function 'rescue_mode': w+board/buffalo/lsxl/lsxl.c:230:8: warning: unused variable 'enetaddr' [-Wunused-variable] arm: + lschlv2 w+board/buffalo/lsxl/lsxl.c: In function 'rescue_mode': w+board/buffalo/lsxl/lsxl.c:230:8: warning: unused variable 'enetaddr' [-Wunused-variable]
Remove the unused variable.
Signed-off-by: Joe Hershberger <joe.hershberger@ni.com>
show more ...
|
#
3238639d |
| 20-May-2015 |
Tom Rini <trini@konsulko.com> |
Merge git://git.denx.de/u-boot-net
|
Revision tags: v2015.07-rc1 |
|
#
76ec988b |
| 04-May-2015 |
Joe Hershberger <joe.hershberger@ni.com> |
net: Remove all calls to net_random_ethaddr()
Remove the calls to net_random_ethaddr() that some boards and some drivers are calling. This is now implemented inside of net/eth.c
Enable the feature
net: Remove all calls to net_random_ethaddr()
Remove the calls to net_random_ethaddr() that some boards and some drivers are calling. This is now implemented inside of net/eth.c
Enable the feature for all boards that previously enabled it.
Signed-off-by: Joe Hershberger <joe.hershberger@ni.com> Acked-By: Michael Walle <michael@walle.cc> (for the lsxl board part)
Series-changes: 2 -Fixed bfin build errors
show more ...
|
#
b939689c |
| 05-May-2015 |
Albert ARIBAUD <albert.u.boot@aribaud.net> |
Merge branch 'u-boot/master' into 'u-boot-arm/master'
|
Revision tags: v2015.04 |
|
#
0adb5b76 |
| 08-Apr-2015 |
Joe Hershberger <joe.hershberger@ni.com> |
net: cosmetic: Name ethaddr variables consistently
Use "_ethaddr" at the end of variables and drop CamelCase. Make constant values actually 'const'.
Signed-off-by: Joe Hershberger <joe.hershberger@
net: cosmetic: Name ethaddr variables consistently
Use "_ethaddr" at the end of variables and drop CamelCase. Make constant values actually 'const'.
Signed-off-by: Joe Hershberger <joe.hershberger@ni.com> Acked-by: Simon Glass <sjg@chromium.org>
show more ...
|
Revision tags: v2015.04-rc5, v2015.04-rc4, v2015.04-rc3, v2015.04-rc2, v2015.04-rc1, v2015.01, v2015.01-rc4, v2015.01-rc3, v2015.01-rc2, v2015.01-rc1 |
|
#
96c5f081 |
| 22-Oct-2014 |
Stefan Roese <sr@denx.de> |
arm: kirkwood: Change naming of dram functions from km_foo() to mvebu_foo()
Additionally the SDRAM address decoding register address is not hard coded in the C code any more. A define is introduced
arm: kirkwood: Change naming of dram functions from km_foo() to mvebu_foo()
Additionally the SDRAM address decoding register address is not hard coded in the C code any more. A define is introduced for this base address.
This makes is possible to use those gpio functions from other MVEBU SoC's as well.
Signed-off-by: Stefan Roese <sr@denx.de> Tested-by: Luka Perkov <luka@openwrt.org> Acked-by: Prafulla Wadaskar <prafulla@marvell.com>
show more ...
|
#
d5c5132f |
| 22-Oct-2014 |
Stefan Roese <sr@denx.de> |
arm: marvell: Extract kirkwood gpio functions into new common file gpio.c
This makes is possible to use those gpio functions from other MVEBU SoC's as well.
Signed-off-by: Stefan Roese <sr@denx.de>
arm: marvell: Extract kirkwood gpio functions into new common file gpio.c
This makes is possible to use those gpio functions from other MVEBU SoC's as well.
Signed-off-by: Stefan Roese <sr@denx.de> Tested-by: Luka Perkov <luka@openwrt.org> Acked-by: Prafulla Wadaskar <prafulla@marvell.com>
show more ...
|
#
3dc23f78 |
| 22-Oct-2014 |
Stefan Roese <sr@denx.de> |
arm: marvell: Move arch/kirkwood.h to arch/soc.h
This move makes is possible to use this header not only from kirkwood platforms but from all Marvell mvebu platforms.
Signed-off-by: Stefan Roese <s
arm: marvell: Move arch/kirkwood.h to arch/soc.h
This move makes is possible to use this header not only from kirkwood platforms but from all Marvell mvebu platforms.
Signed-off-by: Stefan Roese <sr@denx.de> Tested-by: Luka Perkov <luka@openwrt.org> Acked-by: Prafulla Wadaskar <prafulla@marvell.com>
show more ...
|
#
68e80fdd |
| 22-Oct-2014 |
Tom Rini <trini@ti.com> |
Merge git://git.denx.de/u-boot-dm
|
Revision tags: v2014.10 |
|
#
ff0960f9 |
| 14-Oct-2014 |
Simon Glass <sjg@chromium.org> |
sf: Tidy up public and private header files
Since spi_flash.h is supposed to be the public API for SPI flash, move private things to sf_internal.h. Also tidy up a few comment nits.
Signed-off-by: S
sf: Tidy up public and private header files
Since spi_flash.h is supposed to be the public API for SPI flash, move private things to sf_internal.h. Also tidy up a few comment nits.
Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-by: Jagannadha Sutradharudu Teki <jagannadh.teki@gmail.com>
show more ...
|
Revision tags: v2014.10-rc3, v2014.10-rc2, v2014.10-rc1, v2014.07, v2014.07-rc4, v2014.07-rc3, v2014.07-rc2 |
|
#
05d134b0 |
| 20-May-2014 |
Albert ARIBAUD <albert.u.boot@aribaud.net> |
Merge remote-tracking branch 'u-boot/master'
Conflicts: boards.cfg
Conflicts were trivial once u-boot-arm/master boards.cfg was reformatted (commit 6130c146) to match u-boot/master's own reformatt
Merge remote-tracking branch 'u-boot/master'
Conflicts: boards.cfg
Conflicts were trivial once u-boot-arm/master boards.cfg was reformatted (commit 6130c146) to match u-boot/master's own reformatting (commit 1b37fa83).
show more ...
|
#
4180b3db |
| 14-May-2014 |
Marek Vasut <marex@denx.de> |
Merge remote-tracking branch 'u-boot/master' into test
|
Revision tags: v2014.07-rc1 |
|
#
da384a9d |
| 18-Apr-2014 |
Masahiro Yamada <yamada.m@jp.panasonic.com> |
net: rename and refactor eth_rand_ethaddr() function
Some functions in include/net.h are ported from include/linux/etherdevice.h of Linux Kernel.
For ex. is_zero_ether_addr() is_multicast_ether
net: rename and refactor eth_rand_ethaddr() function
Some functions in include/net.h are ported from include/linux/etherdevice.h of Linux Kernel.
For ex. is_zero_ether_addr() is_multicast_ether_addr() is_broadcast_ether_addr() is_valid_ether_addr();
So, we should use the same function name as that of Linux Kernel, eth_rand_addr(), for consistency.
Besides, eth_rand_addr() has been implemented as an inline function. So it should not be surrounded by #ifdef CONFIG_RANDOM_MACADDR.
Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com> Acked-by: Joe Hershberger <joe.hershberger@ni.com>
show more ...
|
Revision tags: v2014.04, v2014.04-rc3, v2014.04-rc2, v2014.04-rc1, v2014.01, v2014.01-rc3, v2014.01-rc2, v2014.01-rc1, v2013.10, v2013.10-rc4, v2013.10-rc3, v2013.10-rc2, v2013.10-rc1 |
|
#
326ea986 |
| 31-Jul-2013 |
Stefano Babic <sbabic@denx.de> |
Merge git://git.denx.de/u-boot-arm
Conflicts: board/freescale/mx6qsabrelite/Makefile board/freescale/mx6qsabrelite/mx6qsabrelite.c include/configs/mx6qsabrelite.h
Signed-off-by: Stefano Babic <s
Merge git://git.denx.de/u-boot-arm
Conflicts: board/freescale/mx6qsabrelite/Makefile board/freescale/mx6qsabrelite/mx6qsabrelite.c include/configs/mx6qsabrelite.h
Signed-off-by: Stefano Babic <sbabic@denx.de>
show more ...
|
#
8b485ba1 |
| 25-Jul-2013 |
Albert ARIBAUD <albert.u.boot@aribaud.net> |
Merge branch 'u-boot/master' into u-boot-arm/master
|
Revision tags: v2013.07, v2013.07-rc3 |
|
#
1a459660 |
| 08-Jul-2013 |
Wolfgang Denk <wd@denx.de> |
Add GPL-2.0+ SPDX-License-Identifier to source files
Signed-off-by: Wolfgang Denk <wd@denx.de> [trini: Fixup common/cmd_io.c] Signed-off-by: Tom Rini <trini@ti.com>
|
Revision tags: v2013.07-rc2, v2013.07-rc1, v2013.04, v2013.04-rc3, v2013.04-rc2, v2013.04-rc1, v2013.01.01, v2013.01 |
|
#
7a8e739c |
| 11-Jan-2013 |
Tom Rini <trini@ti.com> |
Merge branch 'master' of git://git.denx.de/u-boot-arm
|
Revision tags: v2013.01-rc3 |
|
#
ea33fb1a |
| 09-Jan-2013 |
Albert ARIBAUD <albert.u.boot@aribaud.net> |
Merge branch 'u-boot-marvell/master' into 'u-boot-arm/master'
|
Revision tags: v2013.01-rc2, v2013.01-rc1, v2012.10, v2012.10-rc3 |
|
#
23c9946a |
| 04-Oct-2012 |
Michael Walle <michael@walle.cc> |
lsxl: unset ncip for rescue mode
Instead of using the serverip we get from the DHCP server, implicitly use the broadcast address, which is automatically set when no ncip environment variable is set.
lsxl: unset ncip for rescue mode
Instead of using the serverip we get from the DHCP server, implicitly use the broadcast address, which is automatically set when no ncip environment variable is set. That way it isn't necessary to use a special DHCP configuration to set the netconsole peer.
Signed-off-by: Michael Walle <michael@walle.cc> Cc: Prafulla Wadaskar <prafulla@marvell.com>
show more ...
|
#
9d86f0c3 |
| 26-Nov-2012 |
Albert ARIBAUD <albert.u.boot@aribaud.net> |
kirkwood: make MPP arrays static const
This saves stack and code memory for local copy, and consumes initialized data memory. For 22 of the 29 kirkwood-based boards, this results in a global saving
kirkwood: make MPP arrays static const
This saves stack and code memory for local copy, and consumes initialized data memory. For 22 of the 29 kirkwood-based boards, this results in a global saving of about 30 bytes. For 7 of them, it results in an increase of 6 to 14 bytes.
Signed-off-by: Albert ARIBAUD <albert.u.boot@aribaud.net>
show more ...
|
#
19816687 |
| 04-Oct-2012 |
Tom Rini <trini@ti.com> |
Merge branch 'master' of git://git.denx.de/u-boot-arm
|