#
0c9a33d6 |
| 13-Sep-2021 |
Adriana Kobylak <anoo@us.ibm.com> |
clang updates
The openbmc CI was recently updated to clang-12 which requires some formatting updates to the code: https://github.com/openbmc/openbmc-build-scripts/commit/4569bf49daaebff06be048242690
clang updates
The openbmc CI was recently updated to clang-12 which requires some formatting updates to the code: https://github.com/openbmc/openbmc-build-scripts/commit/4569bf49daaebff06be0482426908bb5497fad08
Make those updates and refresh the clang-format file with the one from docs: https://github.com/openbmc/docs/blob/master/style/cpp/.clang-format
Change-Id: Ieb3626526373a053ec84431e7560003f229f338d Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
show more ...
|
#
9462e066 |
| 15-Sep-2020 |
Shawn McCarney <shawnmm@us.ibm.com> |
FileDescriptor: Add move and close methods
Made the following enhancements to the FileDescriptor class: * Moved header file from file.hpp to file_descriptor.hpp to match naming convention used in
FileDescriptor: Add move and close methods
Made the following enhancements to the FileDescriptor class: * Moved header file from file.hpp to file_descriptor.hpp to match naming convention used in other files. * Added move constructor and move assignment operator so FileDescriptor objects can be put in containers like std::vector. * Added close() method so users of class can optionally close the descriptor explicitly and check the return code for errors. If not explicitly closed, the descriptor will still be closed by the destructor which ignores errors. * Added automated tests * Added doxygen comments
Signed-off-by: Shawn McCarney <shawnmm@us.ibm.com> Change-Id: I1e05bbb232443ed1a79728768aaaa1efac8707ec
show more ...
|
#
ab093328 |
| 09-Oct-2019 |
Lei YU <mine260309@gmail.com> |
Refactor: rename namespace witherspoon to phosphor
This repo now becomes phosphor-power, rename namespace witherspoon to phosphor to make it generic.
Signed-off-by: Lei YU <mine260309@gmail.com> Ch
Refactor: rename namespace witherspoon to phosphor
This repo now becomes phosphor-power, rename namespace witherspoon to phosphor to make it generic.
Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: Icb9f8a7c33065add99f2bf42ed55745a28fa0424
show more ...
|
#
f0f02b9a |
| 25-Oct-2018 |
Matt Spinler <spinler@us.ibm.com> |
Start using .clang-format
Used the one from docs/style/cpp.
Change-Id: I3bdc2b353bf18a437266b362d8205b8463a9ce2b Signed-off-by: Matt Spinler <spinler@us.ibm.com>
|
#
35aa1433 |
| 18-Jan-2018 |
Matt Spinler <spinler@us.ibm.com> |
Add support to set a GPIO either low or high
Change-Id: I07379f0cb63dc714cf538e4100f1a01077391f37 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
|
#
da2e0fe9 |
| 18-Jan-2018 |
Matt Spinler <spinler@us.ibm.com> |
Move GPIO class to common library
It will soon by used by the power supply code as well as the power sequencer code, so moving it to a common location.
Change-Id: Ia3e2bcf27239c6861fcb6a9d45ae08a4e
Move GPIO class to common library
It will soon by used by the power supply code as well as the power sequencer code, so moving it to a common location.
Change-Id: Ia3e2bcf27239c6861fcb6a9d45ae08a4eed778b7 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
show more ...
|