History log of /openbmc/hiomapd/lpc.c (Results 1 – 10 of 10)
Revision Date Author Comments
# 0297e5b8 14-Mar-2019 Andrew Jeffery <andrew@aj.id.au>

mboxd: Remove flash API compatibility shim

The flash API compatibility was kept to reduce the line noise in the
previous backend patch. Remove the compatibility layer now and convert

mboxd: Remove flash API compatibility shim

The flash API compatibility was kept to reduce the line noise in the
previous backend patch. Remove the compatibility layer now and convert
the remaining call-sites.

Change-Id: I4b6e54f4463059a7804918add81e7572db7b7c21
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>

show more ...


# f1e547c7 13-Mar-2019 Evan Lojewski <github@meklort.com>

mboxd: Add a backend abstraction layer to mboxd.

Introduce a backend abstraction, enabling multiple implementations to be
compiled in at once. This change formally abstracts the two exis

mboxd: Add a backend abstraction layer to mboxd.

Introduce a backend abstraction, enabling multiple implementations to be
compiled in at once. This change formally abstracts the two existing
backends, mtd and vpnor.

With the backend abstraction in place, subsequent backends are easier to
implement.

This change is based of Evan's work and he retains authorship credit. I
(AJ) have reworked the patch to pass the vpnor tests, refactored some
parts to enable broader use of const structures and others to clarify
the initialisation sequences.

Due to the existing lack of abstraction the patch has unfortunately
wide-ranging impacts. I've whittled it down as much as I consider
reasonable.

Change-Id: I29984a36dae4ea86ec00b853d2a756f0b9afb3ec
Signed-off-by: Evan Lojewski <github@meklort.com>
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>

show more ...


# 26558dbb 09-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

mboxd: Refactor and rename mbox.h to mboxd.h

Refine the purpose of the header file to represent what's required for
the daemon itself, not its constituent pieces. Rather, split those

mboxd: Refactor and rename mbox.h to mboxd.h

Refine the purpose of the header file to represent what's required for
the daemon itself, not its constituent pieces. Rather, split those
definitions out to their respective header files and include them as
necessary.

Finally the header file is renamed to better reflect its purpose.

Change-Id: I48c409f57d96c844589cd865b24f197477dfe87c
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>

show more ...


# 8eab2151 09-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

mboxd: Cleanup errnos not captured by tests

Change-Id: I95d1eee536e4113867fceb5dcda45e15dc032002
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>


# 1e531afd 06-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

protocol: Add get_info

Change-Id: Ie3338714813bb65f5d37fcd046dd5bebc0ba21f0
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>


# 17079d1d 08-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

lpc: Rename point_to_memory to lpc_map_memory

Change-Id: Iee32689e1c222a422aadf217d1fb0c817250de6b
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>


# ec0f2305 08-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

lpc: Rename point_to_flash lpc_map_flash

Change-Id: Id4f28611fed387c35e23acc3ec824e395e097202
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>


# 2e2df286 08-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

lpc: Rename free_lpc_dev to lpc_dev_free

Change-Id: I515ca2aad13d43698c3f4c9fed270d719b92f0f6
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>


# cb9b2100 08-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

lpc: Rename init_lpc_dev to lpc_dev_init

Change-Id: I1b3d8f4b561fda13dee8c9c0460aa463d6200e1d
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>


# cd18611e 07-Aug-2018 Andrew Jeffery <andrew@aj.id.au>

mboxd: Rename lpc source files

Change-Id: I289618c90b2df8911e362397b7eab99403c86c05
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>