1SUMMARY = "Creates an 'xuser' account used for running X11"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5SRC_URI = "file://system-xuser.conf"
6
7inherit allarch useradd
8
9do_configure() {
10    :
11}
12
13do_compile() {
14    :
15}
16
17do_install() {
18    install -D -m 0644 ${WORKDIR}/system-xuser.conf ${D}${sysconfdir}/dbus-1/system.d/system-xuser.conf
19}
20
21FILES_${PN} = "${sysconfdir}/dbus-1/system.d/system-xuser.conf"
22
23USERADD_PACKAGES = "${PN}"
24USERADD_PARAM_${PN} = "--create-home \
25                       --groups video,tty,audio,input,shutdown,disk \
26                       --user-group xuser"
27
28ALLOW_EMPTY_${PN} = "1"
29