1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "92c1b97bfdb4a94acc1cabcaf97eef52dc29144c"
11PV .= "+git"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \
14"
15
16S = "${WORKDIR}/git"
17
18FILES:${PN} = "${bindir}/ptest-runner ${bindir}/ptest-runner-collect-system-data"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23	oe_runmake
24}
25
26do_install () {
27	install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
28	install -D -m 0755 ${S}/ptest-runner-collect-system-data ${D}${bindir}/ptest-runner-collect-system-data
29}
30
31RDEPENDS:${PN}:append:libc-glibc = " libgcc"
32
33# pstree is called by ptest-runner-collect-system-data
34RDEPENDS:${PN}:append = " pstree"
35
36# Create a non-root user that test suites can use easily
37inherit useradd
38USERADD_PACKAGES = "${PN}"
39USERADD_PARAM:${PN} = "--system --no-create-home --home / --user-group ptest"
40