1SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
6LICENSE = "GPL-2.0-only & LGPL-2.1-only"
7SECTION = "apps"
8
9inherit autotools-brokensep ptest
10
11LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=9f34c3af4ed6f3f5df0da5f3c0835a43"
12
13SRCREV = "3871b1c42fc71bceadafd745d2eff5dddfc2d67e"
14PV = "2.0.18"
15
16SRC_URI = "git://github.com/numactl/numactl;branch=master;protocol=https \
17           file://Fix-the-test-output-format.patch \
18           file://Makefile \
19           file://run-ptest \
20           file://0001-define-run-test-target.patch \
21           "
22
23S = "${WORKDIR}/git"
24
25LDFLAGS:append:riscv64 = " -latomic"
26LDFLAGS:append:riscv32 = " -latomic"
27
28do_install() {
29    oe_runmake DESTDIR=${D} prefix=${D}/usr install
30    #remove the empty man2 directory
31    rm -r ${D}${mandir}/man2
32}
33
34do_compile_ptest() {
35    oe_runmake test
36}
37
38do_install_ptest() {
39    #install tests binaries
40    local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
41    mynode    nodemap node-parse pagesize prefered randmap realloc_test \
42    tbitmap tshared"
43
44    [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
45    for i in $test_binaries; do
46        install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
47    done
48
49    local test_scripts="checktopology checkaffinity printcpu regress regress2 \
50        shmtest  runltp bind_range"
51    for i in $test_scripts; do
52        install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
53    done
54
55    install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
56    install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
57}
58
59RDEPENDS:${PN}-ptest = "bash"
60