1SUMMARY = "Library for obtaining the call-chain of a program"
2DESCRIPTION = "a portable and efficient C programming interface (API) to determine the call-chain of a program"
3HOMEPAGE = "http://www.nongnu.org/libunwind"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2d80c8ed4062b8339b715f90fa68cc9f"
6DEPENDS += "libatomic-ops"
7DEPENDS:append:libc-musl = " libucontext"
8
9SRC_URI = "http://download.savannah.nongnu.org/releases/libunwind/libunwind-${PV}.tar.gz \
10           file://mips-byte-order.patch \
11           file://mips-coredump-register.patch \
12           file://0005-ppc32-Consider-ucontext-mismatches-between-glibc-and.patch \
13           file://0001-src-Gtrace-remove-unguarded-print-calls.patch \
14           "
15
16SRC_URI[sha256sum] = "4a6aec666991fb45d0889c44aede8ad6eb108071c3554fcdff671f9c94794976"
17
18inherit autotools multilib_header
19
20COMPATIBLE_HOST:riscv32 = "null"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[lzma] = "--enable-minidebuginfo,--disable-minidebuginfo,xz"
24PACKAGECONFIG[zlib] = "--enable-zlibdebuginfo,--disable-zlibdebuginfo,zlib"
25PACKAGECONFIG[latexdocs] = "--enable-documentation, --disable-documentation, latex2man-native"
26
27EXTRA_OECONF = "--enable-static"
28
29# http://errors.yoctoproject.org/Errors/Details/20487/
30ARM_INSTRUCTION_SET:armv4 = "arm"
31ARM_INSTRUCTION_SET:armv5 = "arm"
32
33LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
34
35SECURITY_LDFLAGS:append:libc-musl = " -lssp_nonshared"
36CACHED_CONFIGUREVARS:append:libc-musl = " LDFLAGS='${LDFLAGS} -lucontext'"
37
38do_install:append () {
39	oe_multilib_header libunwind.h
40}
41
42BBCLASSEXTEND = "native"
43