1SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception & MIT & OpenSSL & BSD-3-Clause & Zlib & ISC & LGPL-2.1-or-later & CC0-1.0 & BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5bdf47bbc9a39dc6ce076d59e322dc17"
5
6DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.7;protocol=https"
9SRCREV = "a418d9d4ab87bae16b87d8f37143a4687ae0e4b2"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16    -DBUILD_TESTS=OFF \
17    -DCMAKE_BUILD_TYPE=RelWithDebInfo \
18    -DREGEX_BACKEND='pcre2' \
19"
20
21BBCLASSEXTEND = "native"
22