1SUMMARY  = "Check - unit testing framework for C code"
2DESCRIPTION = "It features a simple interface for defining unit tests, \
3putting little in the way of the developer. Tests are run in a separate \
4address space, so both assertion failures and code errors that cause \
5segmentation faults or other signals can be caught. Test results are \
6reportable in the following: Subunit, TAP, XML, and a generic logging format."
7HOMEPAGE = "https://libcheck.github.io/check/"
8SECTION = "devel"
9
10LICENSE  = "LGPL-2.1-or-later"
11LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
12
13SRC_URI = "https://github.com/${BPN}/check/releases/download/${PV}/check-${PV}.tar.gz \
14           file://not-echo-compiler-info-to-check_stdint.h.patch"
15SRC_URI[sha256sum] = "a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a"
16UPSTREAM_CHECK_URI = "https://github.com/libcheck/check/releases/"
17
18S = "${WORKDIR}/check-${PV}"
19
20inherit autotools pkgconfig texinfo
21
22CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
23
24RREPLACES:${PN} = "check (<= 0.9.5)"
25
26do_install:append:class-native() {
27    create_cmdline_shebang_wrapper ${D}${bindir}/checkmk
28}
29BBCLASSEXTEND = "native nativesdk"
30
31PACKAGES =+ "checkmk"
32
33FILES:checkmk = "${bindir}/checkmk"
34
35RDEPENDS:checkmk = "gawk"
36
37