1SUMMARY = "in-depth comparison of files, archives, and directories"
2DESCRIPTION = "Tries to get to the bottom of what makes files or directories \
3different. It will recursively unpack archives of many kinds and transform \
4various binary formats into more human-readable form to compare them. \
5It can compare two tarballs, ISO images, or PDF just as easily."
6HOMEPAGE = "https://diffoscope.org/"
7BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues"
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11PYPI_PACKAGE = "diffoscope"
12
13inherit pypi setuptools3
14
15SRC_URI[sha256sum] = "405a55502c8b2c988e46c0800d6a93e8e4e7632c1542b0a540dda50aeea41dac"
16
17RDEPENDS:${PN} += "\
18        binutils \
19        python3-curses \
20        python3-difflib \
21        python3-fcntl \
22        python3-json \
23        python3-libarchive-c \
24        python3-magic \
25        python3-multiprocessing \
26        python3-pprint \
27        python3-rpm \
28        squashfs-tools \
29        vim \
30        "
31
32# Dependencies don't build for musl
33COMPATIBLE_HOST:libc-musl = 'null'
34
35do_install:append:class-native() {
36	create_wrapper ${D}${bindir}/diffoscope \
37		MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
38		RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
39		LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
40		RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
41}
42
43BBCLASSEXTEND = "native"
44