1SUMMARY = "Framework for defining and tracking users, login sessions, and seats"
2DESCRIPTION = "It provides a mechanism for software to react to changes \
3of any of these items or of any of the metadata associated with them."
4HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ConsoleKit"
5BUGTRACKER = "https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
9                    file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3"
10
11DEPENDS = "glib-2.0 glib-2.0-native dbus dbus-glib virtual/libx11"
12RDEPENDS:${PN} += "base-files"
13
14inherit autotools pkgconfig features_check
15# depends on virtual/libx11
16REQUIRED_DISTRO_FEATURES = "x11"
17
18SRC_URI = "http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-${PV}.tar.xz \
19           file://sepbuildfix.patch \
20           file://add-polkit-configure-argument.patch \
21"
22
23SRC_URI[md5sum] = "611792b4d616253a5bdec9175f8b7678"
24SRC_URI[sha256sum] = "b41d17e06f80059589fbeefe96ad07bcc564c49e65516da1caf975146475565c"
25
26S = "${WORKDIR}/ConsoleKit-${PV}"
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd polkit', d)}"
29
30PACKAGECONFIG[pam] = "--enable-pam-module --with-pam-module-dir=${base_libdir}/security,--disable-pam-module,libpam"
31PACKAGECONFIG[polkit] = "--with-polkit,--without-polkit,polkit"
32PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--with-systemdsystemunitdir="
33
34FILES:${PN} += "${exec_prefix}/lib/ConsoleKit \
35                ${libdir}/ConsoleKit  ${systemd_unitdir} ${base_libdir} \
36                ${datadir}/dbus-1 ${datadir}/PolicyKit ${datadir}/polkit*"
37
38PACKAGES =+ "pam-plugin-ck-connector"
39FILES:pam-plugin-ck-connector += "${base_libdir}/security/*.so"
40RDEPENDS:pam-plugin-ck-connector += "${PN}"
41
42do_install:append() {
43	if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
44		install -d ${D}${sysconfdir}/tmpfiles.d
45		echo "d ${localstatedir}/log/ConsoleKit - - - -" \
46			> ${D}${sysconfdir}/tmpfiles.d/consolekit.conf
47	fi
48
49	# Remove /var/ directories as the daemon creates them as required
50	rm -rf ${D}${localstatedir}
51}
52