1SUMMARY = "General-purpose library specifically developed for the WPE-flavored port of WebKit."
2HOMEPAGE = "https://github.com/WebPlatformForEmbedded/libwpe"
3BUGTRACKER = "https://github.com/WebPlatformForEmbedded/libwpe/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"
7DEPENDS = "virtual/egl libxkbcommon"
8
9inherit cmake features_check pkgconfig
10
11REQUIRED_DISTRO_FEATURES = "opengl"
12
13SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[sha256sum] = "c7f3a3c6b3d006790d486dc7cceda2b6d2e329de07f33bc47dfc53f00f334b2a"
15
16# This is a tweak of upstream-version-is-even needed because
17# ipstream directory contains tarballs for other components as well.
18UPSTREAM_CHECK_REGEX = "libwpe-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"
19