xref: /openbmc/openbmc/poky/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb (revision f079ad7e47d674943dc841bd3f5a81887b2ad092)
1SUMMARY = "Provides an icon to shut down the system cleanly"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5SRC_URI = "file://shutdown.desktop"
6
7
8S = "${WORKDIR}"
9
10do_install() {
11	install -d ${D}${datadir}/applications
12	install -m 0644 shutdown.desktop ${D}${datadir}/applications/
13
14	sed -i ${D}${datadir}/applications/shutdown.desktop -e 's#^Exec=\(.*\)#Exec=${base_sbindir}/\1#'
15}
16
17pkg_postinst:${PN} () {
18    grep -q qemuarm $D${sysconfdir}/hostname && \
19        sed -i $D${datadir}/applications/shutdown.desktop -e 's#^Exec=\(.*\)/halt#Exec=\1/reboot#' \
20        || true
21}
22
23inherit allarch
24