1SUMMARY = "Simon Tatham's Portable Puzzle Collection"
2DESCRIPTION = "Collection of small computer programs which implement one-player puzzle games."
3HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE;md5=92d2b7a2fc96b5f7f17101df7db1fefa"
6
7# gtk support includes a bunch of x11 headers
8REQUIRED_DISTRO_FEATURES = "x11"
9
10SRC_URI = "git://git.tartarus.org/simon/puzzles.git;branch=main;protocol=https"
11
12UPSTREAM_CHECK_COMMITS = "1"
13SRCREV = "b6c842a28cf6597df063fcff35079c3e3982381e"
14PE = "2"
15PV = "0.0+git"
16
17S = "${WORKDIR}/git"
18
19inherit cmake features_check pkgconfig
20
21DEPENDS += "gtk+3"
22
23do_install:append () {
24    # net conflicts with Samba, so rename it
25    mv ${D}${bindir}/net ${D}${bindir}/puzzles-net
26    rm ${D}/${datadir}/applications/net.desktop
27
28    # Create desktop shortcuts
29    install -d ${D}/${datadir}/applications/
30    cd ${D}/${prefix}/bin
31    for prog in *; do
32	if [ -x $prog ]; then
33            # Convert prog to Title Case
34            title=$(echo $prog | sed 's/puzzles-//' | sed 's/\(^\| \)./\U&/g')
35	    echo "making ${D}/${datadir}/applications/$prog.desktop"
36	    cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
37[Desktop Entry]
38Name=$title
39Exec=${bindir}/$prog
40Icon=applications-games
41Terminal=false
42Type=Application
43Categories=Game;
44StartupNotify=true
45STOP
46        fi
47    done
48}
49
50