1#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Sato desktop"
6DESCRIPTION = "Packagegroups provide a convenient mechanism of bundling a collection of packages."
7HOMEPAGE = "https://www.yoctoproject.org/"
8PR = "r33"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12inherit packagegroup features_check
13REQUIRED_DISTRO_FEATURES = "x11"
14
15PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
16
17RDEPENDS:${PN} = "\
18    ${PN}-base \
19    ${PN}-apps \
20    ${PN}-games \
21    "
22
23NETWORK_MANAGER ?= "connman-gnome"
24
25SUMMARY:${PN}-base = "Sato desktop - base packages"
26RDEPENDS:${PN}-base = "\
27    matchbox-desktop \
28    matchbox-session-sato \
29    matchbox-keyboard \
30    matchbox-keyboard-applet \
31    matchbox-keyboard-im \
32    matchbox-config-gtk \
33    xcursor-transparent-theme \
34    sato-icon-theme \
35    settings-daemon \
36    shutdown-desktop \
37    ${NETWORK_MANAGER} \
38    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'udev-extraconf', d)} \
39    ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \
40    "
41
42FILEMANAGER ?= "pcmanfm"
43
44WEB ?= ""
45#WEB = "epiphany"
46
47GSTEXAMPLES ?= "gst-examples"
48GSTEXAMPLES:riscv64 = ""
49
50SUMMARY:${PN}-apps = "Sato desktop - applications"
51RDEPENDS:${PN}-apps = "\
52    l3afpad \
53    matchbox-terminal \
54    sato-screenshot \
55    ${FILEMANAGER} \
56    ${GSTEXAMPLES} \
57    ${WEB} \
58    "
59
60SUMMARY:${PN}-games = "Sato desktop - games"
61RDEPENDS:${PN}-games = "\
62    puzzles \
63    "
64