1eb8dc403SDave Cobbleyrequire recipes-core/images/core-image-minimal.bb
2eb8dc403SDave Cobbley
3eb8dc403SDave Cobbley# Skip processing of this recipe if linux-yocto-rt is not explicitly specified as the
4eb8dc403SDave Cobbley# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5eb8dc403SDave Cobbley# to build multiple virtual/kernel providers.
6eb8dc403SDave Cobbleypython () {
7eb8dc403SDave Cobbley    if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
8eb8dc403SDave Cobbley        raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
9eb8dc403SDave Cobbley}
10eb8dc403SDave Cobbley
11eb8dc403SDave CobbleyDESCRIPTION = "A small image just capable of allowing a device to boot plus a \
12eb8dc403SDave Cobbleyreal-time test suite and tools appropriate for real-time use."
13*c342db35SBrad BishopDEPENDS += "linux-yocto-rt"
14eb8dc403SDave Cobbley
15eb8dc403SDave CobbleyIMAGE_INSTALL += "rt-tests hwlatdetect"
16eb8dc403SDave Cobbley
17eb8dc403SDave CobbleyLICENSE = "MIT"
18