1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data.  This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "libtiff"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "67160e3457365ab96c5b3286a0903aa6e78bdc44c4bc737d2e486bcecb6ba976"
14
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
18CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
19CVE_STATUS[CVE-2023-52356] = "fixed-version: Fixed since 4.7.0, NVD tracks this as version-less vulnerability"
20CVE_STATUS[CVE-2023-6228] = "fixed-version: Fixed since 4.7.0, NVD tracks this as version-less vulnerability"
21CVE_STATUS[CVE-2023-6277] = "fixed-version: Fixed since 4.7.0, NVD tracks this as version-less vulnerability"
22
23inherit autotools multilib_header
24
25CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
26
27PACKAGECONFIG ?= "cxx jpeg zlib lzma \
28                  strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
29
30PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
31PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
32PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
33PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
34PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
35PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
36PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
37PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
38
39# Convert single-strip uncompressed images to multiple strips of specified
40# size (default: 8192) to reduce memory usage
41PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
42
43# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
44PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
45
46# Control picking up YCbCr subsample info. Disable to support files lacking
47# the tag
48PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
49
50# Support a mechanism allowing reading large strips (usually one strip files)
51# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
52PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
53
54PACKAGES =+ "tiffxx tiff-utils"
55FILES:tiffxx = "${libdir}/libtiffxx.so.*"
56FILES:tiff-utils = "${bindir}/*"
57
58do_install:append() {
59    oe_multilib_header tiffconf.h
60}
61
62BBCLASSEXTEND = "native nativesdk"
63