xref: /openbmc/openbmc/poky/meta/recipes-multimedia/libtiff/tiff_4.7.0.bb (revision 8460358c3d24c71d9d38fd126c745854a6301564)
1*8460358cSPatrick WilliamsSUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2*8460358cSPatrick WilliamsDESCRIPTION = "Library provides support for the Tag Image File Format \
3*8460358cSPatrick Williams(TIFF), a widely used format for storing image data.  This library \
4*8460358cSPatrick Williamsprovide means to easily access and create TIFF image files."
5*8460358cSPatrick WilliamsHOMEPAGE = "http://www.libtiff.org/"
6*8460358cSPatrick WilliamsLICENSE = "libtiff"
7*8460358cSPatrick WilliamsLIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8*8460358cSPatrick Williams
9*8460358cSPatrick WilliamsCVE_PRODUCT = "libtiff"
10*8460358cSPatrick Williams
11*8460358cSPatrick WilliamsSRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
12*8460358cSPatrick Williams
13*8460358cSPatrick WilliamsSRC_URI[sha256sum] = "67160e3457365ab96c5b3286a0903aa6e78bdc44c4bc737d2e486bcecb6ba976"
14*8460358cSPatrick Williams
15*8460358cSPatrick Williams# exclude betas
16*8460358cSPatrick WilliamsUPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17*8460358cSPatrick Williams
18*8460358cSPatrick WilliamsCVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
19*8460358cSPatrick WilliamsCVE_STATUS[CVE-2023-52356] = "fixed-version: Fixed since 4.7.0, NVD tracks this as version-less vulnerability"
20*8460358cSPatrick WilliamsCVE_STATUS[CVE-2023-6228] = "fixed-version: Fixed since 4.7.0, NVD tracks this as version-less vulnerability"
21*8460358cSPatrick WilliamsCVE_STATUS[CVE-2023-6277] = "fixed-version: Fixed since 4.7.0, NVD tracks this as version-less vulnerability"
22*8460358cSPatrick Williams
23*8460358cSPatrick Williamsinherit autotools multilib_header
24*8460358cSPatrick Williams
25*8460358cSPatrick WilliamsCACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
26*8460358cSPatrick Williams
27*8460358cSPatrick WilliamsPACKAGECONFIG ?= "cxx jpeg zlib lzma \
28*8460358cSPatrick Williams                  strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
29*8460358cSPatrick Williams
30*8460358cSPatrick WilliamsPACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
31*8460358cSPatrick WilliamsPACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
32*8460358cSPatrick WilliamsPACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
33*8460358cSPatrick WilliamsPACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
34*8460358cSPatrick WilliamsPACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
35*8460358cSPatrick WilliamsPACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
36*8460358cSPatrick WilliamsPACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
37*8460358cSPatrick WilliamsPACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
38*8460358cSPatrick Williams
39*8460358cSPatrick Williams# Convert single-strip uncompressed images to multiple strips of specified
40*8460358cSPatrick Williams# size (default: 8192) to reduce memory usage
41*8460358cSPatrick WilliamsPACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
42*8460358cSPatrick Williams
43*8460358cSPatrick Williams# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
44*8460358cSPatrick WilliamsPACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
45*8460358cSPatrick Williams
46*8460358cSPatrick Williams# Control picking up YCbCr subsample info. Disable to support files lacking
47*8460358cSPatrick Williams# the tag
48*8460358cSPatrick WilliamsPACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
49*8460358cSPatrick Williams
50*8460358cSPatrick Williams# Support a mechanism allowing reading large strips (usually one strip files)
51*8460358cSPatrick Williams# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
52*8460358cSPatrick WilliamsPACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
53*8460358cSPatrick Williams
54*8460358cSPatrick WilliamsPACKAGES =+ "tiffxx tiff-utils"
55*8460358cSPatrick WilliamsFILES:tiffxx = "${libdir}/libtiffxx.so.*"
56*8460358cSPatrick WilliamsFILES:tiff-utils = "${bindir}/*"
57*8460358cSPatrick Williams
58*8460358cSPatrick Williamsdo_install:append() {
59*8460358cSPatrick Williams    oe_multilib_header tiffconf.h
60*8460358cSPatrick Williams}
61*8460358cSPatrick Williams
62*8460358cSPatrick WilliamsBBCLASSEXTEND = "native nativesdk"
63