1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data.  This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
12           file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data.patch \
13           file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data-2.patch \
14           file://CVE-2023-6277-Apply-1-suggestion-s-to-1-file-s.patch \
15           file://CVE-2023-6228.patch \
16           file://CVE-2023-52355-0001.patch \
17           file://CVE-2023-52355-0002.patch \
18           file://CVE-2023-52356.patch \
19           "
20
21SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a"
22
23# exclude betas
24UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
25
26CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
27CVE_STATUS[CVE-2023-3164] = "cpe-incorrect: Issue only affects the tiffcrop tool not compiled by default since 4.6.0"
28
29inherit autotools multilib_header
30
31CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
32
33PACKAGECONFIG ?= "cxx jpeg zlib lzma \
34                  strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
35
36PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
37PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
38PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
39PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
40PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
41PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
42PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
43PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
44
45# Convert single-strip uncompressed images to multiple strips of specified
46# size (default: 8192) to reduce memory usage
47PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
48
49# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
50PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
51
52# Control picking up YCbCr subsample info. Disable to support files lacking
53# the tag
54PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
55
56# Support a mechanism allowing reading large strips (usually one strip files)
57# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
58PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
59
60PACKAGES =+ "tiffxx tiff-utils"
61FILES:tiffxx = "${libdir}/libtiffxx.so.*"
62FILES:tiff-utils = "${bindir}/*"
63
64do_install:append() {
65    oe_multilib_header tiffconf.h
66}
67
68BBCLASSEXTEND = "native nativesdk"
69