1SUMMARY = "Initscript for auto-loading kernel modules on boot"
2SECTION = "base"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://modutils.sh;beginline=3;endline=3;md5=b2dccaa94b3629a08bfb4f983cad6f89"
5SRC_URI = "file://modutils.sh"
6
7PR = "r7"
8
9S = "${WORKDIR}"
10
11INITSCRIPT_NAME = "modutils.sh"
12INITSCRIPT_PARAMS = "start 06 S ."
13
14inherit update-rc.d
15
16do_compile () {
17}
18
19do_install () {
20	install -d ${D}${sysconfdir}/init.d/
21	install -m 0755 ${WORKDIR}/modutils.sh ${D}${sysconfdir}/init.d/
22}
23
24PACKAGE_WRITE_DEPS:append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
25pkg_postinst:${PN} () {
26	if type systemctl >/dev/null 2>/dev/null; then
27		if [ -n "$D" ]; then
28			OPTS="--root=$D"
29		fi
30		systemctl $OPTS mask modutils.service
31	fi
32}
33