1SUMMARY = "Build tools needed by external modules"
2HOMEPAGE = "https://www.yoctoproject.org/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
5
6inherit kernel-arch
7inherit pkgconfig
8
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11S = "${WORKDIR}"
12
13do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot"
14do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
15
16RDEPENDS:${PN}-dev = ""
17
18DEPENDS += "bc-native bison-native"
19DEPENDS += "gmp-native"
20
21EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
22EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}" CROSS_COMPILE=${TARGET_PREFIX}"
23
24# Build some host tools under work-shared.  CC, LD, and AR are probably
25# not used, but this is the historical way of invoking "make scripts".
26#
27do_configure() {
28	unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
29	for t in prepare scripts_basic scripts; do
30		oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
31		-C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t
32	done
33}
34