1SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window.  The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations.  The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT"
13LIC_FILES_CHKSUM = "file://COPYING;md5=8fc8ae699974c360e2e2e883a63ce264"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.xz"
16SRC_URI[sha256sum] = "f02cd6b957295e0d50236a3db15825256c92f67ef1f73bf1c77a4b179edf728f"
17
18SECTION = "x11/libs"
19DEPENDS = "util-macros libxslt-native"
20
21EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
22
23FILES:${PN} += "${datadir}/X11/xkb"
24
25inherit meson pkgconfig gettext python3native
26
27do_install:append () {
28    install -d ${D}${datadir}/X11/xkb/compiled
29    cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
30}
31
32BBCLASSEXTEND += "native"
33