1SUMMARY = "Xlib: C Language X Interface library"
2
3DESCRIPTION = "This package provides a client interface to the X Window \
4System, otherwise known as 'Xlib'.  It provides a complete API for the \
5basic functions of the window system."
6
7require xorg-lib-common.inc
8
9LICENSE = "MIT & BSD-1-Clause & HPND & HPND-sell-variant & ISC"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1d49cdd2b386c5db11ec636d680b7116"
11
12DEPENDS += "xorgproto \
13            xtrans \
14            libxcb \
15            xorgproto-native \
16            autoconf-archive-native \
17            "
18
19PROVIDES = "virtual/libx11"
20
21PE = "1"
22
23XORG_PN = "libX11"
24
25SRC_URI += "file://disable_tests.patch"
26
27SRC_URI[sha256sum] = "2b3b3dad9347db41dca56beb7db5878f283bde1142f04d9f8e478af435dfdc53"
28
29inherit gettext
30
31EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
32EXTRA_OEMAKE += 'CWARNFLAGS=""'
33
34PACKAGECONFIG ??= "xcms"
35PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
36
37PACKAGES =+ "${PN}-xcb"
38
39FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
40FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*"
41FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
42
43BBCLASSEXTEND = "native nativesdk"
44