1DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
2HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
4LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https \
9           file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
10           file://debugfix.patch \
11           file://0001-Qualify-move-as-std-move.patch;patchdir=third_party/spirv-cross \
12           "
13
14UPSTREAM_CHECK_COMMITS = "1"
15SRCREV = "74d45aace02d99d766126711a8aaa0978276ca00"
16
17UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
18S = "${WORKDIR}/git"
19
20REQUIRED_DISTRO_FEATURES = 'vulkan'
21COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux"
22
23inherit cmake features_check
24
25FILES:${PN} += "${datadir}"
26
27#
28# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
29# used for logging with LOGE in the code. We need to make this match the value we use
30# in the debug source remapping from CFLAGS
31#
32EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
33# Binaries built with PCH enabled don't appear reproducible, differing results were seen
34# from some builds depending on the point the PCH was compiled. Disable it to be
35# deterministic
36EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
37
38# This needs to be specified explicitly to avoid xcb/xlib dependencies
39EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"
40