1SUMMARY = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
2HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
4LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=main;protocol=https;lfs=0 \
9           file://0001-vulkan-samples-Fix-reproducibility-issue.patch \
10           "
11
12UPSTREAM_CHECK_COMMITS = "1"
13SRCREV = "4838e02a4b08236931bec0532fc26ee3871b466a"
14
15UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
16S = "${WORKDIR}/git"
17
18REQUIRED_DISTRO_FEATURES = 'vulkan'
19
20inherit cmake features_check
21
22FILES:${PN} += "${datadir}"
23
24#
25# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
26# used for logging with LOGE in the code. We need to make this match the value we use
27# in the debug source remapping from CFLAGS
28#
29EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=${TARGET_DBGSRC_DIR}/"
30# Binaries built with PCH enabled don't appear reproducible, differing results were seen
31# from some builds depending on the point the PCH was compiled. Disable it to be
32# deterministic
33EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
34
35# This needs to be specified explicitly to avoid xcb/xlib dependencies
36EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"
37
38COMPATIBLE_HOST = "(aarch64|x86_64).*-linux"
39